New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Quasar 1.0 is released!!!!!!!! #41

Open
thearabbit opened this Issue Feb 8, 2019 · 17 comments

Comments

Projects
None yet
4 participants
@thearabbit
Copy link

thearabbit commented Feb 8, 2019

@thearabbit

This comment has been minimized.

Copy link
Author

thearabbit commented Feb 9, 2019

I tried, but get error

import Quasar from 'quasar'
------------------------
Uncaught Error: Cannot find module 'quasar'
    at makeMissingError (modules-runtime.js?hash=d3c3e5d67c95f97a60888bda7373292efad3be5e:232)
    at Module.require (modules-runtime.js?hash=d3c3e5d67c95f97a60888bda7373292efad3be5e:251)
    at Module.moduleLink [as link] (modules.js?hash=235183ca901a1e5610984473a56483095ea17662:285)
    at main.js (main.js:1)
    at fileEvaluate (modules-runtime.js?hash=d3c3e5d67c95f97a60888bda7373292efad3be5e:346)
    at Module.require (modules-runtime.js?hash=d3c3e5d67c95f97a60888bda7373292efad3be5e:248)
    at require (modules-runtime.js?hash=d3c3e5d67c95f97a60888bda7373292efad3be5e:268)
    at app.js?hash=c6c5b9e948103b389f4f2ea5ebdac249dc26f90e:260
@rstoenescu

This comment has been minimized.

Copy link
Member

rstoenescu commented Feb 9, 2019

Hi @mwarren2 ! Please connect with me to help get this bumped to 1.0. Thanks!

@mwarren2

This comment has been minimized.

Copy link
Collaborator

mwarren2 commented Feb 9, 2019

@rstoenescu @thearabbit I've got urgent work to do today, I'll be in contact as soon as I can look at this

@rstoenescu

This comment has been minimized.

Copy link
Member

rstoenescu commented Feb 9, 2019

@mwarren2 No rush. At your own pace. I'll be available for you.

@thearabbit

This comment has been minimized.

Copy link
Author

thearabbit commented Feb 9, 2019

Very thanks for all 💯.
Waiting you...

@mwarren2

This comment has been minimized.

Copy link
Collaborator

mwarren2 commented Feb 11, 2019

@thearabbit How did you update to the beta?

I would like very much to try the beta, but I'm not keen on updating here unless it's easy for other people to do so. The beta isn't on npm.

@thearabbit

This comment has been minimized.

Copy link
Author

thearabbit commented Feb 11, 2019

Quasar changed npm name on 1.0.

// package.json
{
  "name": "meteor-quasar1",
  "private": true,
  "scripts": {
    "start": "meteor run",
    "test": "meteor test --once --driver-package meteortesting:mocha",
    "test-app": "TEST_WATCH=1 meteor test --full-app --driver-package meteortesting:mocha",
    "visualize": "meteor --production --extra-packages bundle-visualizer"
  },
  "dependencies": {
    "@babel/runtime": "^7.1.5",
    "@quasar/extras": "^1.0.0",
    "lodash": "^4.17.11",
    "meteor-node-stubs": "^0.4.1",
    "quasar": "^1.0.0-beta.0",
    "vue": "^2.6.4",
    "vue-router": "^3.0.2",
    "vuex": "^3.1.0"
  },
  "meteor": {
    "mainModule": {
      "client": "client/main.js",
      "server": "server/main.js"
    },
    "testModule": "tests/main.js"
  }
}
@thearabbit

This comment has been minimized.

Copy link
Author

thearabbit commented Feb 11, 2019

main.js

.......
// Quasar globally
import '@quasar/extras/material-icons/material-icons.css'
import 'quasar/dist/quasar.min.css'
import Quasar from 'quasar/dist/quasar.esm.js' // work fine (ln -s /node_modules/quasar imports)
import langEn from 'quasar/lang/en-us'

// import Quasar  from 'quasar' // don't work
// import { Quasar } from 'quasar/dist/quasar.esm.js' // don't work (don't want to declare with globally)
// import Quasar from 'quasar/dist/quasar.umd.min.js' // don't wrok


Vue.use(Quasar, {
  lang: langEn,
})
......
@mwarren2

This comment has been minimized.

Copy link
Collaborator

mwarren2 commented Feb 11, 2019

Ah, so it's been renamed to quasar from quasar-framework, that explains it.
Ok, I'll take a look

@thearabbit

This comment has been minimized.

Copy link
Author

thearabbit commented Feb 11, 2019

I am not sure

image

@nothingismagick

This comment has been minimized.

Copy link

nothingismagick commented Feb 12, 2019

@mwarren2 - I highly recommend you visit the discord channel and join the conversation. You are always welcome!

@thearabbit

This comment has been minimized.

Copy link
Author

thearabbit commented Feb 12, 2019

@mwarren2

This comment has been minimized.

Copy link
Collaborator

mwarren2 commented Feb 12, 2019

@thearabbit A little patience, I haven't actually been able to look at it, I've got a lot on my plate.
I'll be trying it out in the next couple of days

@thearabbit

This comment has been minimized.

Copy link
Author

thearabbit commented Feb 12, 2019

No problem

@mwarren2

This comment has been minimized.

Copy link
Collaborator

mwarren2 commented Feb 13, 2019

@thearabbit I've got Quasar 1.0.0 working, but there are many, many breaking changes to the ui, so this is going to take a while.

@thearabbit

This comment has been minimized.

Copy link
Author

thearabbit commented Feb 13, 2019

Haha, working on import Quasar from 'quasar'?

@nothingismagick

This comment has been minimized.

Copy link

nothingismagick commented Feb 14, 2019

@mwarren2 - there is a worksheet about this that the core team has been putting together with some of our early adopters: https://gist.github.com/hawkeye64/da4b4d662ab1484bd0b532ffd871679e

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment