Skip to content
Permalink
Browse files

feat(docs): Update QIcon cheatsheet

  • Loading branch information...
rstoenescu committed Aug 25, 2019
1 parent 2c7c853 commit 92782131e83bb34f8f3fcc1e385f4df386a34f6c
Showing with 3 additions and 0 deletions.
  1. +1 −0 docs/src/pages/vue-components/icon.md
  2. +2 −0 extras/README.md
@@ -35,6 +35,7 @@ Make sure that you [installed the icon library](/options/installing-icon-librari
| material-icons-sharp | s_ | s_thumb_up | Notice the underline character instead of dash or space; **Requires Quasar 1.0.5+** |
| ionicons-v4 | ion-, ion-md-, ion-ios-, ion-logo- | ion-heart, ion-logo-npm, ion-md-airplane | Use QIcon instead of `<ion-icon>` component; Logo icons require 'ion-logo-' prefix |
| fontawesome-v5 | fa[s,r,l,b] fa- | "fas fa-ambulance" | QIcon "name" property is same as "class" attribute value in Fontawesome docs examples (where they show `<i>` tags) |
| mdi-v4 | mdi- | mdi-alert-circle-outline | Notice the use of dash characters |
| mdi-v3 | mdi- | mdi-alert-circle-outline | Notice the use of dash characters |
| eva-icons | eva- | eva-shield-outline, eva-activity-outline | Notice the use of dash characters |
| themify | ti- | ti-hand-point-up | Notice the use of dash characters |
@@ -30,6 +30,8 @@ Please make sure you have latest `@quasar/extras` npm package version installed
| [Themify Icons](https://themify.me/themify-icons) | `themify` | 1.0.0 | Themify Icons font | |
| [Animate.css](https://daneden.github.io/animate.css/) | Use `animations` prop | 3.5.2 | Bundle of animations you can use in your website/app | |
> Either install MDI v4 or MDI v3, but never both at the same time.
Why this package? Because it strips down unnecessary package files (so faster download times), all in one place, tested and ready to use with Quasar. One other reason is that the material icons npm package sometimes fails to be downloaded by NPM.
### QIcon cheatsheet

0 comments on commit 9278213

Please sign in to comment.
You can’t perform that action at this time.