New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Found no mapping for -150 (all_parameters.default_value sql_variant) #1098

Closed
mrtinkz opened this Issue Dec 18, 2014 · 4 comments

Comments

Projects
None yet
2 participants
@mrtinkz

mrtinkz commented Dec 18, 2014

Please see below exception, I am a little confused as this error is raised after it say's Exported all_objects successfully.

All I am trying to do is, trying to export QModel objects from the database. I see the QSources being generated but could not come to a conclusion as why this error is shown. Any help is greatly appreciated.

Thanks

[INFO] Exported CHECK_CONSTRAINTS successfully
[INFO] Exported COLUMN_DOMAIN_USAGE successfully
[INFO] Exported COLUMN_PRIVILEGES successfully
[INFO] Exported COLUMNS successfully
[INFO] Exported CONSTRAINT_COLUMN_USAGE successfully
[INFO] Exported CONSTRAINT_TABLE_USAGE successfully
[INFO] Exported DOMAIN_CONSTRAINTS successfully
[INFO] Exported DOMAINS successfully
[INFO] Exported KEY_COLUMN_USAGE successfully
[INFO] Exported PARAMETERS successfully
[INFO] Exported REFERENTIAL_CONSTRAINTS successfully
[INFO] Exported ROUTINE_COLUMNS successfully
[INFO] Exported ROUTINES successfully
[INFO] Exported SCHEMATA successfully
[INFO] Exported TABLE_CONSTRAINTS successfully
[INFO] Exported TABLE_PRIVILEGES successfully
[INFO] Exported TABLES successfully
[INFO] Exported VIEW_COLUMN_USAGE successfully
[INFO] Exported VIEW_TABLE_USAGE successfully
[INFO] Exported VIEWS successfully
[INFO] Exported all_columns successfully
[INFO] Exported all_objects successfully
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 39.969 s
[INFO] Finished at: 2014-12-18T15:09:25-06:00
[INFO] Final Memory: 24M/397M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal com.mysema.querydsl:querydsl-maven-plugin:3.6.0:export (generate-schema-dsl) on project ef-model: Execution generate-schema-dsl of goal com.mysema.querydsl:querydsl-maven-plugin:3.6.0:export failed: Found no mapping for -150 (all_parameters.default_value sql_variant) -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal com.mysema.querydsl:querydsl-maven-plugin:3.6.0:export (generate-schema-dsl) on project ef-model: Execution generate-schema-dsl of goal com.mysema.querydsl:querydsl-maven-plugin:3.6.0:export failed: Found no mapping for -150 (all_parameters.default_value sql_variant)
    at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:224)
    at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
    at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
    at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:108)
    at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:76)
    at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
    at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:116)
    at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:361)
    at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:155)
    at org.apache.maven.cli.MavenCli.execute(MavenCli.java:584)
    at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:213)
    at org.apache.maven.cli.MavenCli.main(MavenCli.java:157)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
    at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
    at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
    at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
Caused by: org.apache.maven.plugin.PluginExecutionException: Execution generate-schema-dsl of goal com.mysema.querydsl:querydsl-maven-plugin:3.6.0:export failed: Found no mapping for -150 (all_parameters.default_value sql_variant)
    at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:144)
    at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208)
    ... 19 more
Caused by: java.lang.IllegalStateException: Found no mapping for -150 (all_parameters.default_value sql_variant)
    at com.mysema.query.sql.codegen.MetaDataExporter.handleColumn(MetaDataExporter.java:259)
    at com.mysema.query.sql.codegen.MetaDataExporter.handleTable(MetaDataExporter.java:334)
    at com.mysema.query.sql.codegen.MetaDataExporter.export(MetaDataExporter.java:229)
    at com.mysema.query.maven.AbstractMetaDataExportMojo.execute(AbstractMetaDataExportMojo.java:410)
    at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:133)
    ... 20 more
[ERROR] 
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginExecutionException
@timowest

This comment has been minimized.

Show comment
Hide comment
@timowest

timowest Dec 19, 2014

Member

Which database do you use?

Member

timowest commented Dec 19, 2014

Which database do you use?

@mrtinkz

This comment has been minimized.

Show comment
Hide comment
@mrtinkz

mrtinkz Dec 20, 2014

I am using mssql sqlserver. Thank you.

mrtinkz commented Dec 20, 2014

I am using mssql sqlserver. Thank you.

@timowest

This comment has been minimized.

Show comment
Hide comment
@timowest

timowest Dec 21, 2014

Member

Could you try the latest version (3.6.0) instead? It will give you a more informative error message.

Member

timowest commented Dec 21, 2014

Could you try the latest version (3.6.0) instead? It will give you a more informative error message.

@mrtinkz

This comment has been minimized.

Show comment
Hide comment
@mrtinkz

mrtinkz Dec 26, 2014

Hi Tim,

Am using the same version.

<querydsl.version>3.6.0</querydsl.version>

mrtinkz commented Dec 26, 2014

Hi Tim,

Am using the same version.

<querydsl.version>3.6.0</querydsl.version>

@timowest timowest added this to the 4.0.0 milestone Feb 7, 2015

@timowest timowest added the progress label Feb 7, 2015

@Shredder121 Shredder121 closed this in #1180 Feb 11, 2015

@timowest timowest removed the progress label Feb 11, 2015

@timowest timowest removed the progress label Mar 13, 2015

@timowest timowest modified the milestones: 3.6.2, 4.0.0 Mar 31, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment