New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

javax.persistence package should be imported with version [1.1.0,2.1.0) #148

Closed
alexeyr opened this Issue May 14, 2012 · 1 comment

Comments

Projects
None yet
2 participants
@alexeyr

alexeyr commented May 14, 2012

Currently javax.persistence package is imported in MANIFEST.MF with minimum version 2.0, but some bundles export it with version 1.1.0 with attribute jpa="2.0". E.g. Apache Geronimo JPA 2.0 Spec bundle, and some versions of EclipseLink javax.persistence bundle. See http://wiki.eclipse.org/EclipseLink/Examples/OSGi#Importing_Javax.Persistence_2.0 and https://bugs.eclipse.org/bugs/show_bug.cgi?id=337827. Import-Package:javax.persistence;version:="[1.1.0,2.1.0)" should work with all JPA 2.0 bundles, AFAIK.

timowest added a commit that referenced this issue May 14, 2012

@timowest

This comment has been minimized.

Show comment
Hide comment
@timowest

timowest May 25, 2012

Member

Released in 2.6.0

Member

timowest commented May 25, 2012

Released in 2.6.0

@timowest timowest closed this May 25, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment