Maven test execution fails for collection queries #170

Closed
olivergierke opened this Issue Jun 12, 2012 · 4 comments

Comments

Projects
None yet
2 participants
@olivergierke

I have set up some projections on a collection inside a test case. It can be execute fine in Eclipse but the default configuration for the Maven surefire plugin fails with this exception message. Configuring Surefire to not fork (<forkMode>never</forkMode>) resolves the problem.

@timowest

This comment has been minimized.

Show comment
Hide comment
@timowest

timowest Jun 12, 2012

Member

I just changed the default classloader to the current thread's context classloader. Could you try again with the latest snapshot 2.6.0.BUILD-SNAPSHOT?

Member

timowest commented Jun 12, 2012

I just changed the default classloader to the current thread's context classloader. Could you try again with the latest snapshot 2.6.0.BUILD-SNAPSHOT?

@timowest

This comment has been minimized.

Show comment
Hide comment

timowest added a commit that referenced this issue Jun 16, 2012

@timowest

This comment has been minimized.

Show comment
Hide comment
@timowest

timowest Jun 16, 2012

Member

fixed in external codegen module

Member

timowest commented Jun 16, 2012

fixed in external codegen module

@timowest

This comment has been minimized.

Show comment
Hide comment
@timowest

timowest Jun 28, 2012

Member

Released in 2.7.0

Member

timowest commented Jun 28, 2012

Released in 2.7.0

@timowest timowest closed this Jun 28, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment