update Apache Commons dependencies #40

Closed
rpmcfong opened this Issue Nov 6, 2011 · 2 comments

Comments

Projects
None yet
2 participants
@rpmcfong

rpmcfong commented Nov 6, 2011

Several third party libraries are out of date. Amongst them:

  • collections-generic-4.01.jar & commons-collections-3.1.jar; replace with Apache Commons

<dependency>
<groupId>commons-collections</groupId>
<artifactId>commons-collections</artifactId>
<version>3.2.1</version>
</dependency>

  • commons-io-1.4.jar; out-of-date, update to 2.1

<dependency>
<groupId>commons-io</groupId>
<artifactId>commons-io</artifactId>
<version>2.1</version>
</dependency>

  • commons-lang-2.4.jar; out-of-date, update to 3.0.1

<dependency>
<groupId>org.apache.commons</groupId>
<artifactId>commons-lang3</artifactId>
<version>3.0.1</version>
</dependency>

@timowest

This comment has been minimized.

Show comment
Hide comment
@timowest

timowest Nov 7, 2011

Member

Commons Collections 3.2.1 is not generics enabled, it seems. I will stick to Collections generic 4.01 unless you find an offical generic version.

Member

timowest commented Nov 7, 2011

Commons Collections 3.2.1 is not generics enabled, it seems. I will stick to Collections generic 4.01 unless you find an offical generic version.

timowest added a commit that referenced this issue Nov 7, 2011

timowest added a commit that referenced this issue Nov 7, 2011

@timowest

This comment has been minimized.

Show comment
Hide comment
@timowest

timowest Nov 19, 2011

Member

Released in 2.2.5

Member

timowest commented Nov 19, 2011

Released in 2.2.5

@timowest timowest closed this Nov 19, 2011

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment