querydsl-jpa does not export package com.mysema.query.jpa.impl #879

Closed
jaromirecek opened this Issue Aug 5, 2014 · 3 comments

Comments

Projects
None yet
3 participants
@jaromirecek

In OSGi enviroment i am not able to use querydsl-jpa and OpenJPA. When i use new JPAQuery i must import it but this class is in "impl" package and this package is not exported by querydsl-jpa bundle. Solution can be manualy export package com.mysema.query.impl.

@timowest

This comment has been minimized.

Show comment
Hide comment
@timowest

timowest Aug 6, 2014

Member

It appears the BND plugin excludes "impl" packages by default http://felix.apache.org/site/apache-felix-maven-bundle-plugin-bnd.html

Member

timowest commented Aug 6, 2014

It appears the BND plugin excludes "impl" packages by default http://felix.apache.org/site/apache-felix-maven-bundle-plugin-bnd.html

@timowest timowest added this to the 3.4.3 milestone Aug 6, 2014

@timowest timowest added the bug label Aug 6, 2014

@timowest timowest closed this in #882 Aug 6, 2014

@ieugen

This comment has been minimized.

Show comment
Hide comment
@ieugen

ieugen Aug 13, 2014

+1 for this package. I'm trying to use querydsl with deltaspike data [1] integration in OSGI and I've hit this bug.

[1] http://deltaspike.apache.org/data.html

ieugen commented Aug 13, 2014

+1 for this package. I'm trying to use querydsl with deltaspike data [1] integration in OSGI and I've hit this bug.

[1] http://deltaspike.apache.org/data.html

@timowest

This comment has been minimized.

Show comment
Hide comment
@timowest

timowest Aug 31, 2014

Member

Released in 3.4.3

Member

timowest commented Aug 31, 2014

Released in 3.4.3

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment