Skip to content
Browse files

bug: fix json dependency - now works with bare rails apps

pull request: #1

big thanks to https://github.com/jtrim
  • Loading branch information...
1 parent d88dfeb commit f3769766666f3a2fd7a869495c0aff208a8004b3 Ryan Cook committed Feb 8, 2011
Showing with 10 additions and 2 deletions.
  1. +3 −0 Gemfile.lock
  2. +4 −0 lib/regulate/git/model/base.rb
  3. +3 −2 regulate.gemspec
View
3 Gemfile.lock
@@ -4,6 +4,7 @@ PATH
regulate (0.1.1)
abstract_auth (~> 0.1.3)
grit (~> 2.3.0)
+ json (~> 1.4.6)
rails (~> 3.0.0)
GEM
@@ -63,6 +64,7 @@ GEM
diff-lcs (~> 1.1)
mime-types (~> 1.15)
i18n (0.5.0)
+ json (1.4.6)
json_pure (1.4.6)
mail (2.2.14)
activesupport (>= 2.3.6)
@@ -116,6 +118,7 @@ DEPENDENCIES
bundler (~> 1.0.0)
capybara (~> 0.4.0)
grit (~> 2.3.0)
+ json (~> 1.4.6)
rails (~> 3.0.0)
regulate!
sqlite3-ruby (~> 1.3.2)
View
4 lib/regulate/git/model/base.rb
@@ -6,6 +6,10 @@ module Model
# Our standard base class for all git resources
class Base
+
+ # Requires
+ require 'json'
+
# Standard ActiveModel includes so that our resources are Rails friendly
include ActiveModel::Validations
include ActiveModel::Conversion
View
5 regulate.gemspec
@@ -14,9 +14,10 @@ Gem::Specification.new do |s|
s.rubyforge_project = "regulate"
- s.add_dependency "rails", "~> 3.0.0"
- s.add_dependency "grit", "~> 2.3.0"
s.add_dependency "abstract_auth", "~> 0.1.3"
+ s.add_dependency "grit", "~> 2.3.0"
+ s.add_dependency "json", "~> 1.4.6"
+ s.add_dependency "rails", "~> 3.0.0"
s.add_development_dependency "bluecloth", "~> 2.0.9"
s.add_development_dependency "bundler", "~> 1.0.0"
s.add_development_dependency "capybara", "~> 0.4.0"

0 comments on commit f376976

Please sign in to comment.
Something went wrong with that request. Please try again.