Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Text Entry Mode: i-Beam is always black and hard to see on dark background #1171

Closed
ar-rm opened this issue Oct 13, 2012 · 3 comments
Closed

Comments

@ar-rm
Copy link

ar-rm commented Oct 13, 2012

Hi,

In Text Entry Mode, the i-Beam (cursor, insertion point, etc.) is always black, regardless of the color that's been set for "Text" in the Appearance prefs. As a result, if you've set the background color to something very dark or black, you can't see the i-Beam among the text. Which makes fixing typos particularly hard. I have to switch to The Force™ to make corrections.

I use Nostromo, but the same is true for Bezel (Built-In).

I'm pretty sure this started with QS ß70 (3935).

I think this might be related to this "New" item from the release notes:

"Colors in text entry mode are based on those of the results list (adjustable in the Appearance prefs next to "Lists"). Text no longer shows in the background as you type. (#1029)"

I imagine the way to fix this is to make sure the i-Beam is the same color as the "Appearance > Lists > Text" color. Or you could get fancy and make the i-Beam color automatically changes to a pre-defined light/dark color based on the "Appearance > Lists > Background" color.

Thanks!

a.

@pjrobertson
Copy link
Member

pjrobertson commented Oct 13, 2012

I have also noticed this problem with ß70, and have been looking at a fix.
I will try and make sure it is fixed in ß71

On 13 October 2012 17:15, ar notifications@github.com wrote:

Hi,

In Text Entry Mode, the i-Beam (cursor, insertion point, etc.) is always
black, regardless of the color that's been set for "Text" in the Appearance
prefs. As a result, if you've set the background color to something very
dark or black, you can't see the i-Beam among the text. Which makes fixing
typos particularly hard. I have to switch to The Force™ to make corrections.

I use Nostromo, but the same is true for Bezel (Built-In).

I'm pretty sure this started with QS ß70 (3935).

I think this might be related to this "New" item from the release notes:

"Colors in text entry mode are based on those of the results list
(adjustable in the Appearance prefs next to "Lists"). Text no longer shows
in the background as you type. (#1029#1029
)"

I imagine the way to fix this is to make sure the i-Beam is the same color
as the "Appearance > Lists > Text" color. Or you could get fancy and make
the i-Beam color automatically changes to a pre-defined light/dark color
based on the "Appearance > Lists > Background" color.

Thanks!

a.


Reply to this email directly or view it on GitHubhttps://github.com//issues/1171.

@ar-rm
Copy link
Author

ar-rm commented Oct 13, 2012

That's great.
I look forward to it.

Thanks!

@ar-rm
Copy link
Author

ar-rm commented Nov 17, 2012

Confirmed: Fixed in QS Pre-Release B71 (3936)

Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

2 participants