Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Text doesn't wrap in text entry mode #2127

Closed
Sesquipedalian opened this issue Oct 16, 2015 · 6 comments · Fixed by #2652
Closed

Text doesn't wrap in text entry mode #2127

Sesquipedalian opened this issue Oct 16, 2015 · 6 comments · Fixed by #2652

Comments

@Sesquipedalian
Copy link

Using QS 1.3.1 and OS X 10.11, if I get some text into the first (or third) pane (e.g. by right-arrowing into a text file) and then press the period key to enter text mode, the text does not wrap to the width of the pane's bounding box. Instead, the text remains one one visual line and I have to scroll horizontally to see the rest of the text. On previous versions of QS and OS X, text did wrap.

This affects all the interfaces I have tested, including Bezel, Primer, Nostromo, and Yosemite (https://github.com/mikker/YosemiteInterface-qsplugin)

@Sesquipedalian
Copy link
Author

Just updated QS to 1.3.2. No difference.

@skurfer
Copy link
Member

skurfer commented Oct 17, 2015

Hmmm. I can’t reproduce this in any interface.

screen shot 2015-10-16 at 11 52 38 pm

What settings could we possibly have different that would explain this?

@Sesquipedalian
Copy link
Author

Sorry, my initial description was a little off. I've updated it now. The problem appears when I have a text string as an object in the first pane and then switch to text mode in order to edit it.

@Sesquipedalian
Copy link
Author

Sequence to reproduce:

  1. With first pane is blank, press "." to enter text mode. Enter some text. Word wrap works:
    initial entry - word wrap works
  2. Tab over to second pane, then back to first pane.
  3. Press "." to enter text mode again. Word wrap no longer works:
    editing - word wrap no longer works

@skurfer
Copy link
Member

skurfer commented Oct 17, 2015

Thanks for the additional details. I can reproduce it now.

Wouldn’t surprise me if this is related to so many interfaces crashing when you follow the same steps.

@Guid0mcman
Copy link

Could have sworn there were at least a couple of reports about this on the google group but I can only find the one now...

https://groups.google.com/forum/#!searchin/blacktree-quicksilver/text$20not$20wrapping/blacktree-quicksilver/X_DIE-e9aX0/ZCU9UidMu0kJ

tiennou added a commit that referenced this issue Feb 6, 2016
tiennou added a commit that referenced this issue Jul 22, 2016
pjrobertson added a commit that referenced this issue Feb 16, 2022
Makes sure text wraps in the right place. Fixes #2127
skurfer pushed a commit that referenced this issue Feb 23, 2022
Makes sure text wraps in the right place. Fixes #2127
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

Successfully merging a pull request may close this issue.

3 participants