Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Enforce bundle version requirements #1261

Merged
merged 4 commits into from Dec 20, 2012
Merged

Enforce bundle version requirements #1261

merged 4 commits into from Dec 20, 2012

Conversation

skurfer
Copy link
Member

@skurfer skurfer commented Dec 3, 2012

I was planning to require iTunes 11 for the next version of the plug-in, but it wasn't working. I found there was nothing but a warning where version checking should be. :-)

While in that method, I also localized all the errors.

I've also included one unrelated commit that fixes a warning I ran across.

pjrobertson added a commit that referenced this issue Dec 20, 2012
@pjrobertson pjrobertson merged commit 67fed59 into quicksilver:master Dec 20, 2012
@skurfer skurfer deleted the bundleVersionRequirement branch Dec 20, 2012
@skurfer
Copy link
Member Author

@skurfer skurfer commented Dec 20, 2012

Yeah, so the next release, which is pretty far off. Should we go ahead with it now, knowing it will kill iTunes DJ actions for users of iTunes 10?

Edit
Sorry, this was in reference to the iTunes pull. :-)

@pjrobertson
Copy link
Member

@pjrobertson pjrobertson commented Dec 20, 2012

I haven't looked at the iTunes pull yet, so it might be a bit off (although, you seem to be semi-autonomous on the iTunes plugin anyway, so I'd be happy for you to merge if it now if you really want)

The change is small, so we could merge this into release as well then get the iTunes plugin out for ß71.

@skurfer
Copy link
Member Author

@skurfer skurfer commented Dec 21, 2012

Not sure when this diverged from master. We might have to cherry-pick it into release, which could make a big mess.

Maybe I'll just release the iTunes plug-in now, and if anyone still using 10 complains, I can give a link to the old version. I mainly want to get it out because there are some crashes with iTunes 11.

@pjrobertson
Copy link
Member

@pjrobertson pjrobertson commented Dec 21, 2012

Alright, go for it from my point of view.

At the very least, it may be worth marking the new plugin's maxOSVersion on
the server as 100608 (10.6.8) just so we're ruling out potential non
iTunes 11 users a bit.
http://support.apple.com/kb/DL1614

On 21 December 2012 13:23, Rob McBroom notifications@github.com wrote:

Not sure when this diverged from master. We might have to cherry-pick it
into release, which could make a big mess.

Maybe I'll just release the iTunes plug-in now, and if anyone still using
10 complains, I can give a link to the old version. I mainly want to get it
out because there are some crashes with iTunes 11.


Reply to this email directly or view it on GitHubhttps://github.com//pull/1261#issuecomment-11612505.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants