Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 40 lines (33 sloc) 1.089 kb
8e4b9ce @quirkey Moving to jeweler. Fixed will-paginate issue. Closes #13
authored
1 %w[rubygems rake rake/clean rake/testtask fileutils].each { |f| require f }
19985ce @quirkey Added newgem files (Rakefile mainly)
authored
2 require File.dirname(__FILE__) + '/lib/gembox'
3
8e4b9ce @quirkey Moving to jeweler. Fixed will-paginate issue. Closes #13
authored
4 begin
5 require 'jeweler'
6 rescue LoadError
7 puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"
8 end
9
10 Jeweler::Tasks.new do |s|
11 s.name = %q{gembox}
12 s.version = Gembox::VERSION
13 s.authors = ["Aaron Quint"]
14 s.summary = "A sinatra based interface for browsing and admiring your gems."
15 s.description = "A sinatra based interface for browsing and admiring your gems."
16 s.email = ["aaron@quirkey.com"]
17 s.homepage = %q{http://code.quirkey.com/gembox}
18 s.rubyforge_project = %q{quirkey}
31a6a54 @quirkey Updated tests to use rack/test
authored
19
8e4b9ce @quirkey Moving to jeweler. Fixed will-paginate issue. Closes #13
authored
20 [
21 ['sinatra', '~>1.0'],
22 ['vegas', '~>0.1.0'],
23 ['haml', '~>2.0.9'],
bc342ca @quirkey New version (0.2.0)
authored
24 ['rdoc', '=2.4.3'],
8e4b9ce @quirkey Moving to jeweler. Fixed will-paginate issue. Closes #13
authored
25 ['activesupport', '~>2.2.2'],
26 ['will_paginate', '~>2.3.7']
27 ].each do |n, v|
28 s.add_runtime_dependency(n, v)
29 end
30 end
31
32 Jeweler::GemcutterTasks.new
33
34 Rake::TestTask.new do |t|
35 t.libs << "test"
36 t.test_files = FileList['test/test*.rb']
37 t.verbose = true
edb0db9 @quirkey Updated Version info for latest
authored
38 end
39
Something went wrong with that request. Please try again.