Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Need change dependency activesupport >= 2.2.2 but < 3.0.0 #11

Open
antono opened this Issue Feb 21, 2010 · 5 comments

Comments

Projects
None yet
3 participants

antono commented Feb 21, 2010

/usr/lib/ruby/1.8/rubygems.rb:280:in activate': can't activate activesupport (= 2.3.5, runtime) for [], already activated activesupport-3.0.0.beta for ["gembox-0.2.1"] (Gem::LoadError) from /usr/lib/ruby/1.8/rubygems/custom_require.rb:35:inrequire'
from /var/lib/gems/1.8/gems/gembox-0.2.1/lib/gembox.rb:7
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require' from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:inrequire'
from /var/lib/gems/1.8/gems/gembox-0.2.1/bin/gembox:6
from /var/lib/gems/1.8/bin/gembox:19:in `load'
from /var/lib/gems/1.8/bin/gembox:19

antono commented Feb 21, 2010

original issue was with missing mattr_reader in ActiveSuport 3.0.0

antono commented Feb 21, 2010

$ sudo gem install rails --pre

$ gembox

/var/lib/gems/1.8/gems/mislav-will_paginate-2.3.11/lib/will_paginate/view_helpers.rb:37: undefined method mattr_reader' for WillPaginate::ViewHelpers:Module (NoMethodError) from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:ingem_original_require'
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in require' from /var/lib/gems/1.8/gems/gembox-0.2.1/lib/gembox.rb:10 from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:ingem_original_require'
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in require' from /var/lib/gems/1.8/gems/gembox-0.2.1/bin/gembox:6 from /var/lib/gems/1.8/bin/gembox:19:inload'
from /var/lib/gems/1.8/bin/gembox:19

I am also still getting this even though it was claimed to be closed by https://github.com/quirkey/gembox/issues/closed#issue/13

ches commented Feb 26, 2011

It seems that the issue is require 'active_support' loading ActiveSupport 3+ if it is installed. Changing the require in lib/gembox.rb to require 'activesupport' works for me.

ches commented Feb 26, 2011

How about we just use ActiveSupport 3 and put this behind us?

#14

There's also a fix in there for Gem::Dependency#version_requirements being gone in newer versions of rubygems, if anyone tracking this ticket is hitting that crasher.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment