Couldnt get a file descriptor referring to the console #9

Open
millisami opened this Issue Dec 6, 2009 · 3 comments

Comments

Projects
None yet
2 participants
@millisami

I'm getting the following error while starting gembox:

[~] ➔ gembox rack
[Mon Dec 07 03:11:48 +0545 2009] Starting gembox
[Mon Dec 07 03:11:48 +0545 2009] gembox is already running at http://0.0.0.0:5678
Couldnt get a file descriptor referring to the console

Using REE 1.8.7 with gembox 0.2.1 from gemcutter

@quirkey

This comment has been minimized.

Show comment
Hide comment
@quirkey

quirkey Dec 7, 2009

Owner

What OS are you on? Can you access the app at that port? I have a feeling it has to do with trying to launch the browser.

Owner

quirkey commented Dec 7, 2009

What OS are you on? Can you access the app at that port? I have a feeling it has to do with trying to launch the browser.

@millisami

This comment has been minimized.

Show comment
Hide comment
@millisami

millisami Dec 8, 2009

Well, I'm on Ubuntu Jaunty.
My bad, oops, yes on that port the gembox is running and I can simply access it.
But I don't remember when did I started it last time. Does the gembox starts automatically once installed?

Well, I'm on Ubuntu Jaunty.
My bad, oops, yes on that port the gembox is running and I can simply access it.
But I don't remember when did I started it last time. Does the gembox starts automatically once installed?

@quirkey

This comment has been minimized.

Show comment
Hide comment
@quirkey

quirkey Dec 8, 2009

Owner

OK - that makes sense then. You started it probably when you ran the following above. By default, gembox will daemonize and then try to launch in the browser using 'open' or 'start' depending on the platform. It looks like it started above, but there was an error trying to launch it. I'm not too familiar with Ubuntu as a desktop platform. Is there a way to launch a browser from the command line?

Owner

quirkey commented Dec 8, 2009

OK - that makes sense then. You started it probably when you ran the following above. By default, gembox will daemonize and then try to launch in the browser using 'open' or 'start' depending on the platform. It looks like it started above, but there was an error trying to launch it. I'm not too familiar with Ubuntu as a desktop platform. Is there a way to launch a browser from the command line?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment