Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Upgrading gem dependencies

  • Loading branch information...
commit 8ee51c5962341e747e09d1bfdcac74c83276b53a 1 parent 6d1d2cc
Aaron Quint authored
Showing with 23 additions and 18 deletions.
  1. +4 −3 Gemfile
  2. +15 −8 Gemfile.lock
  3. +3 −3 Rakefile
  4. +1 −4 test/test_macro_plugin.rb
7 Gemfile
View
@@ -6,9 +6,10 @@ gem 'mime-types', '~>1.16'
gem 'typhoeus', '~>0.2.4'
gem 'thor', '~>0.14.0'
gem 'jim', '~>0.3.1'
-gem 'compass', '~>0.10.5'
-gem 'mustache', '~>0.11.2'
-gem 'coffee-script', '~> 2.1.2'
+gem 'compass', '~>0.11'
+gem 'mustache', '~>0.99'
+gem 'coffee-script', '~>2.2'
+
group :development do
gem 'rake'
gem 'jeweler'
23 Gemfile.lock
View
@@ -2,18 +2,23 @@ GEM
remote: http://rubygems.org/
specs:
archive-tar-minitar (0.5.2)
- coffee-script (2.1.3)
+ chunky_png (1.2.5)
+ coffee-script (2.2.0)
coffee-script-source
+ execjs
coffee-script-source (1.1.2)
- compass (0.10.6)
- haml (>= 3.0.4)
+ compass (0.11.5)
+ chunky_png (~> 1.2)
+ fssm (>= 0.2.7)
+ sass (~> 3.1)
downlow (0.1.4)
archive-tar-minitar (>= 0.5.2)
rubyzip (>= 0.9.4)
+ execjs (1.2.9)
+ multi_json (~> 1.0)
fakeweb (1.3.0)
fssm (0.2.7)
git (1.2.5)
- haml (3.1.3)
jeweler (1.6.4)
bundler (~> 1.0)
git (>= 1.2.5)
@@ -43,12 +48,14 @@ GEM
mime-types (1.16)
mocha (0.10.0)
metaclass (~> 0.0.1)
- mustache (0.11.2)
+ multi_json (1.0.3)
+ mustache (0.99.4)
rack (1.3.3)
rack-test (0.6.1)
rack (>= 1.0)
rake (0.9.2)
rubyzip (0.9.4)
+ sass (3.1.8)
shoulda (2.11.3)
test-unit (2.4.0)
thor (0.14.6)
@@ -62,13 +69,13 @@ PLATFORMS
ruby
DEPENDENCIES
- coffee-script (~> 2.1.2)
- compass (~> 0.10.5)
+ coffee-script (~> 2.2)
+ compass (~> 0.11)
jeweler
jim (~> 0.3.1)
json (~> 1.4.6)
mime-types (~> 1.16)
- mustache (~> 0.11.2)
+ mustache (~> 0.99)
rake
shoulda
thor (~> 0.14.0)
6 Rakefile
View
@@ -18,9 +18,9 @@ begin
gem.add_dependency 'typhoeus', '~>0.2.4'
gem.add_dependency 'thor', '~>0.14.0'
gem.add_dependency 'jim', '~>0.3.1'
- gem.add_dependency 'compass', '~>0.10.5'
- gem.add_dependency 'mustache', '~>0.11.2'
- gem.add_dependency 'coffee-script', '~> 2.1.2'
+ gem.add_dependency 'compass', '~>0.12'
+ gem.add_dependency 'mustache', '~>0.99'
+ gem.add_dependency 'coffee-script', '~> 2.2'
gem.add_development_dependency "shoulda", ">= 0"
gem.add_development_dependency "yard", ">= 0"
# gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
5 test/test_macro_plugin.rb
View
@@ -7,15 +7,14 @@ class TestSocaPusher < Test::Unit::TestCase
@pusher = Soca::Pusher.new(@test_app_dir)
@sammy = File.read("#{@test_app_dir}/js/vendor/sammy-0.5.4.js")
@views = "#{@test_app_dir}/db/views/"
+ @pusher.push!
end
should "replace !code macros with file contents" do
- @pusher.push!
assert @pusher.document['views']['recent'].all?{|part| part[1].include?(@sammy)}
end
should "keep the original code" do
- @pusher.push!
parts = ['map','reduce'].inject({}){|res,part| res[part] = File.read("#{@views}/recent/#{part}.js").split("\n");res}
parts.each do |part,lines|
assert contain_lines(part,lines)
@@ -23,10 +22,8 @@ class TestSocaPusher < Test::Unit::TestCase
end
should "be able to process views with map only" do
- @pusher.push!
lines = File.read("#{@views}/only_map/map.js").split("\n")
assert contain_lines('map',lines)
-
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.