Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[regression] mutagen 1.19 fails to open certain FLAC files #67

Closed
lazka opened this issue Jul 4, 2014 · 5 comments
Closed

[regression] mutagen 1.19 fails to open certain FLAC files #67

lazka opened this issue Jul 4, 2014 · 5 comments
Labels

Comments

@lazka
Copy link
Member

@lazka lazka commented Jul 4, 2014

Originally reported by: Christoph Reiter (Bitbucket: lazka, GitHub: lazka)


From cubi...@googlemail.com on June 24, 2010 15:01:16

Hi,

I recently updated mutagen from version 1.18 to 1.19 and noticed a regression with FLAC files.

File example is hosted here: http://www.math.uni-bielefeld.de/~tjakobi/archive/regression.flac The output I'm getting:
Python 2.6.5 (release26-maint, Jun 23 2010, 11:36:49) 
[GCC 4.4.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import mutagen.flac
>>> audio = mutagen.flac.FLAC('APPLESEED ORIGINAL SOUNDTRACK (Disc 1)-track01.flac')
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/mutagen/__init__.py", line 75, in __init__
    self.load(filename, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/mutagen/flac.py", line 587, in load
    raise FLACNoHeaderError("End of metadata did not start audio")
mutagen.flac.FLACNoHeaderError: End of metadata did not start audio

The file was created with flake SVN- r264 (the FLAC encoder where parts are now in ffmpeg), and the tagging was done with foobar2000 0.9.6.8 (through wine).

metaflac can read the tags perfectly and the flac reference decoder shows no warnings/errors.

mutagen 1.18 did handle the files correctly.

Greets,
Tobias

Original issue: http://code.google.com/p/mutagen/issues/detail?id=67


@lazka

This comment has been minimized.

Copy link
Member Author

@lazka lazka commented Jul 4, 2014

Original comment by Christoph Reiter (Bitbucket: lazka, GitHub: lazka):


From joe.wreschnig@gmail.com on June 24, 2010 11:16:49

This issue was closed by revision r87 .

Status: Fixed

@lazka

This comment has been minimized.

Copy link
Member Author

@lazka lazka commented Jul 4, 2014

Original comment by Christoph Reiter (Bitbucket: lazka, GitHub: lazka):


From reiter.christoph@gmail.com on August 29, 2012 05:11:58

Issue 121 has been merged into this issue.
@lazka

This comment has been minimized.

Copy link
Member Author

@lazka lazka commented Jul 4, 2014

Original comment by Christoph Reiter (Bitbucket: lazka, GitHub: lazka):


From cubi...@googlemail.com on June 24, 2010 14:55:41

Woah, that was fast - big thanks!
@lazka

This comment has been minimized.

Copy link
Member Author

@lazka lazka commented Jul 4, 2014

Original comment by Christoph Reiter (Bitbucket: lazka, GitHub: lazka):


From julf.helsingius on August 29, 2012 05:22:27

Thanks! Sorry for not noticing issue #67 before re-reporting the issue.
@lazka

This comment has been minimized.

Copy link
Member Author

@lazka lazka commented Jul 4, 2014

Original comment by Christoph Reiter (Bitbucket: lazka, GitHub: lazka):


From julf.helsingius on August 29, 2012 05:34:08

I still seem to have the issue even with 1.20
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.