New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

notify plugin: album art not working under e19 #1504

Closed
lazka opened this Issue Mar 15, 2015 · 6 comments

Comments

Projects
None yet
1 participant
@lazka
Member

lazka commented Mar 15, 2015

Original issue 1504 created by reiter.christoph on 2014-12-15T20:15:40.000Z:

https://code.google.com/p/quodlibet/issues/detail?id=797#c5

@lazka

This comment has been minimized.

Member

lazka commented Mar 15, 2015

Comment #1 originally posted by gandalf.pk on 2014-12-15T20:28:38.000Z:

Yeah, thanks.

It turns out that the "URI.frompath(image_path)" junks the image_path (filling it with %20 instead of spaces), manually doing something like:

image_path = "file://" + song.find_cover().name

seems to work just fine. I guess until I hit something nasty and it crashes.

Also, for some reason, the:

if "icon-static" in caps

sequence doesn't follow through (on E19).

@lazka

This comment has been minimized.

Member

lazka commented Mar 15, 2015

Comment #2 originally posted by reiter.christoph on 2014-12-15T21:02:56.000Z:

Spaces aren't allowed in file URIs and image_path is defined as a file URI according to the notification spec [0].

Maybe putting the URI in the hints field helps 'hints["image-path"] = image_path'? (besides removing the "icon-static" check)

[0] https://people.gnome.org/~mccann/docs/notification-spec/notification-spec-latest.html#icons-and-images

@lazka

This comment has been minimized.

Member

lazka commented Mar 15, 2015

Comment #3 originally posted by gandalf.pk on 2014-12-15T22:16:42.000Z:

Actually, just removing the check seems to work fine, passing the actual absolute location instead of an URI works.

The "spec" is equal to [1, 2] in E19, by the way - not sure why it doesn't pass "spec >= (1,1)"...

I wonder, is "icon-static" not being listed in capabilities a bug in E19? Should I report it there?

@lazka

This comment has been minimized.

Member

lazka commented Mar 15, 2015

Comment #4 originally posted by reiter.christoph on 2014-12-15T22:40:35.000Z:

Not sure why I checked for "icon-static" there. It's not clear to me what it's for exactly according to the spec (any ideas?). I guess it can be removed.

For the image path we can't change that format since that would break other notification implementations.

Did setting "image-path" to the URI in hints not help?

Is e19 in the default arch repo?

@lazka

This comment has been minimized.

Member

lazka commented Mar 15, 2015

Comment #5 originally posted by reiter.christoph on 2014-12-16T09:32:12.000Z:

Ok, was in the default repo. I'll check it out sometime

@lazka

This comment has been minimized.

Member

lazka commented Mar 15, 2015

Comment #6 originally posted by reiter.christoph on 2014-12-20T18:59:50.000Z:

Fixed the icon-static thing in trunk. Re URI handling: I've filed https://phab.enlightenment.org/T1939

@lazka lazka closed this Mar 15, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment