New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Music time progress bar stay still on 0:00 #1953

Closed
LudoBike opened this Issue May 22, 2016 · 10 comments

Comments

Projects
None yet
6 participants
@LudoBike
Contributor

LudoBike commented May 22, 2016

Hi, I report a bug on the music time progress bar, when I start music it stay still on 0:00 however if I change the time manually the bar work well

Here some info on my OS

# ludovic @ Tardis in ~ [16:48:17] 
$ uname -a
Linux Tardis 4.5.4-1-ARCH #1 SMP PREEMPT Wed May 11 22:21:28 CEST 2016 x86_64 GNU/Linux

# ludovic @ Tardis in ~ [16:48:19] 
$ quodlibet --version
Quod Libet 3.6.1
<quod-libet-development@googlegroups.com>
Copyright © 2004-2016 Joe Wreschnig, Michael Urman, Iñigo Serna, Steven Robertson, Christoph Reiter, Nick Boultbee...
@urielz

This comment has been minimized.

Contributor

urielz commented May 22, 2016

I've come across this issue as well, perhaps half a dozen times in the last year or so. To me it happened at random times while I was doing something else. I couldn't pin down the steps to reproduce it. (OS X QL 3.x)

@lazka

This comment has been minimized.

Member

lazka commented May 22, 2016

Does playback stop as well?

@LudoBike

This comment has been minimized.

Contributor

LudoBike commented May 22, 2016

No the music is in playing but the time stay still

@lazka

This comment has been minimized.

Member

lazka commented May 22, 2016

@urielz does playback also continue in your case?

@urielz

This comment has been minimized.

Contributor

urielz commented May 22, 2016

yes it does. It always happened while I was using QL for something else, like editing tags or browsing on a separate window...

@lazka

This comment has been minimized.

Member

lazka commented May 22, 2016

ok, thanks

@lazka lazka added the bug label May 22, 2016

@kaffeeundsalz

This comment has been minimized.

kaffeeundsalz commented May 24, 2016

Just wanted to say that I've occasionally observed this, too. I can't add much information though, since @urielz has already pointed it all out. Playback continues, can't reproduce steps. Currently QL 3.6.1 on OS X 10.11.5 El Capitan, but the bug showed up in earlier versions, too.

@pierregermain

This comment has been minimized.

pierregermain commented May 26, 2016

I have this also when I change the tags of a (playing) song from the command line.

@CreamyCookie

This comment has been minimized.

Contributor

CreamyCookie commented Jul 1, 2016

At the moment I can reproduce this (even after restarting Quod Libet). All I did was:

  1. Start a song
  2. Wait a few seconds
  3. Drag the seekbar to 0:00
  4. Wait a few seconds
  5. Release the left mouse button (i.e. drop the seekbar)

Now, the music time is always 0:00 even when switching to a different song. I can make it work again by dragging the seekbar to something other than 0:00.

One thing I noticed (which may or may not be related to this bug) is that the music time sometimes lags behind a lot. I just noticed that the music was playing but the time was still 0:00, then it suddenly jumped to 0:06 and started working as usual.

@lazka

This comment has been minimized.

Member

lazka commented Jul 1, 2016

Thanks, I can reproduce given your instructions.

@lazka lazka added this to the 3.7 Release milestone Jul 28, 2016

@lazka lazka closed this in f1956c8 Jul 30, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment