Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

TLS with libsoup not working #2107

Closed
lazka opened this issue Nov 20, 2016 · 0 comments
Closed

TLS with libsoup not working #2107

lazka opened this issue Nov 20, 2016 · 0 comments

Comments

@lazka
Copy link
Member

@lazka lazka commented Nov 20, 2016

Tests are skipped atm: https://github.com/quodlibet/quodlibet/blob/master/quodlibet/tests/test_https.py

It works in my jhbuild env, so either the bundle is missing something or it tries to reference something using a hardcoded path.

declension added a commit that referenced this issue Nov 21, 2016
  * Libsoup broken currently for SSL (#2107)
  * Can be overridden by config, without code change (e.g. as soon as libsoup OSX works again)
  * Print warning and instructions.
  * Disable all authenticated access whilst SSL disabled. This was a bit more paranoid than my first version of this, but seems fairer (searching / playing still works fine)
   * Disable (gray out) UI items to indicate the missing features.
@lazka lazka closed this in decfc72 Nov 21, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant