New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Segfault when calling `path_home()` #58

Closed
kevinushey opened this Issue Jan 31, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@kevinushey
Contributor

kevinushey commented Jan 31, 2018

Some users at rstudio::conf were encountering segfaults when attempting to call path_home(). In fact, the error occurred while attempting to print the path -- unfortunately I don't have the call stack but the process was dying within a call to the stat_ R function with a null pointer dereference.

One user who encountered this was using El Capitan, in case the use of an older toolchain could be an issue.

@jimhester

This comment has been minimized.

Member

jimhester commented Feb 21, 2018

This is likely from the same cause as the build failures on CRAN MacOS builder
https://www.r-project.org/nosvn/R.check/r-release-osx-x86_64/fs-00check.html

Unfortunately I am still unable to reproduce this to figure out the issue

@jimhester

This comment has been minimized.

Member

jimhester commented Mar 12, 2018

Should be fixed by 901cb50

@jimhester jimhester closed this Mar 12, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment