New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Need to link with -lxnet on Solaris #159

Closed
jeroen opened this Issue Nov 5, 2018 · 7 comments

Comments

Projects
None yet
2 participants
@jeroen
Member

jeroen commented Nov 5, 2018

Not sure how CRAN does this but on my Solaris I need PKG_LIBS=-lxnet for socketpair,

@gaborcsardi

This comment has been minimized.

Member

gaborcsardi commented Nov 5, 2018

Yeah, I don't need this on R-hub, either.

@jeroen

This comment has been minimized.

Member

jeroen commented Nov 6, 2018

Are you on Solaris 10 or 11?

@gaborcsardi

This comment has been minimized.

Member

gaborcsardi commented Nov 6, 2018

Oracle Solaris 10, x86, 32 bit, Oracle compilers.

@jeroen

This comment has been minimized.

Member

jeroen commented Nov 6, 2018

Ah okay I'm using GCC. Do the oracle compilers support c++11 now?

@gaborcsardi

This comment has been minimized.

Member

gaborcsardi commented Nov 6, 2018

@gaborcsardi

This comment has been minimized.

Member

gaborcsardi commented Nov 6, 2018

Btw. I can add that flag for gcc, it probably does not hurt for the Oracle compiler, either.

@jeroen

This comment has been minimized.

Member

jeroen commented Nov 6, 2018

It's not important, just wasn't sure why it was failing for me. Probably oracle compilers link this in by default.

@jeroen jeroen closed this Nov 8, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment