Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error with a brand new project #779

Closed
MaksimRudnev opened this issue Aug 11, 2018 · 6 comments
Closed

Error with a brand new project #779

MaksimRudnev opened this issue Aug 11, 2018 · 6 comments

Comments

@MaksimRudnev
Copy link

@MaksimRudnev MaksimRudnev commented Aug 11, 2018

After updating roxygen2 to 6.1.0 it keeps showing the following error, even with the brand new projects set up by RStudio (1.1.456) defaults, i.e. containing a single hello.R file.

First time using roxygen2. Upgrading automatically...
Error in .f(.x[[i]], ...) : attempt to apply non-function
Calls: suppressPackageStartupMessages ... read_pkg_description -> read.description -> <Anonymous> -> .Call -> .f
Execution halted

Exited with status 1.
@rubak
Copy link

@rubak rubak commented Aug 13, 2018

I had the same issue. Updating the desc package to version 1.2.0 fixed it for me.

@fawda123
Copy link

@fawda123 fawda123 commented Aug 15, 2018

@rubak worked for me as well

@MaksimRudnev
Copy link
Author

@MaksimRudnev MaksimRudnev commented Aug 18, 2018

Thanks, it fixed the problem. Update to roxygen 6.1.0.9 fixes it as well.

hadley added a commit that referenced this issue Aug 21, 2018
Require desc 1.2.0

Fixes #777. Fixes #779.
@abhijat-github
Copy link

@abhijat-github abhijat-github commented Jul 17, 2019

I had the same issue. Updating the desc package to version 1.2.0 fixed it for me.

Can you please explain how you updated the desc package. I am quite new to package building in R. Thank you.

@abhijat-github
Copy link

@abhijat-github abhijat-github commented Jul 17, 2019

I get the following error when I try to build my package using Clean and Rebuild under Build Menu

_==> devtools::document(roclets = c('rd', 'collate', 'namespace', 'vignette'))

Updating qmR documentation
First time using roxygen2. Upgrading automatically...
Error in if (any(mismatch <- res != res2)) { :
missing value where TRUE/FALSE needed
Calls: suppressPackageStartupMessages ... idesc_create -> idesc_create_file -> idesc_create_text -> read_dcf
Execution halted

Exited with status 1._

@gaborcsardi
Copy link
Collaborator

@gaborcsardi gaborcsardi commented Jul 17, 2019

Can you please explain how you updated the desc package. I am quite new to package building in R. Thank you.

install.packages("desc")

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
5 participants