A Danger plug-in to suggest code changes through inline comments in pull requests.
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.circleci
bin
images
lib
spec
.gitignore
.rspec
.rubocop.yml
CHANGELOG.md
Dangerfile
Gemfile
Gemfile.lock
LICENSE.txt
README.md
Rakefile
danger-suggester.gemspec

README.md

Danger::Suggester

CircleCI Gem Version Documentation

A Danger plug-in to suggest code changes through inline comments in pull requests.

Suggestions are calculated based on the results of git diff, so any code formatter like rubocop, prettier, go fmt, etc. can be used for this. Note that there is a limitation that multi-line replacements cannot be suggested because GitHub's suggested changes™ doesn't support it.

demo

Requirements

  • Ruby 2.2 or higher

Installation

Add this line to your application's Gemfile:

gem 'danger-suggester'

And then execute:

bundle

Or install it yourself as:

gem install danger-suggester

Usage

Add this line to your application's Dangerfile:

suggester.suggest

And then execute danger after correcting code by your favorite code formatters.

Contributing

Bug reports and pull requests are welcome on GitHub at https://github.com/r7kamura/danger-suggester.

License

The gem is available as open source under the terms of the MIT License.