Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Use default version not working in CentOS #218

Closed
cmluciano opened this issue Feb 6, 2015 · 2 comments

Comments

Projects
None yet
2 participants
@cmluciano
Copy link
Collaborator

commented Feb 6, 2015

While yum-epel has packages for centos 6.5, 6.6, and 7.0- these packages are out of date and therefore will not likely align with the default 3.4.3. I think that the only way that it would, is if someone is replicating these to their own personal server. As such the "default-use-distro-version" test suite will always fail with our default values.

I have come up with a few solutions that I can submit a PR for.

  1. Edit the test-suite "default-use-distro-version" with versions that we know are available in YUM epel. (probably the easiest and most clean)
  2. Create a new test-suite in mini-test fashion and import a repo that might have up to date versions.
  3. Deprecate this feature in CentOS since the packages from yum-epel are several x.Y.z behind.
@jjasghar

This comment has been minimized.

Copy link
Collaborator

commented Feb 6, 2015

Great points. I'm leaning towards to 1 out of these; it seems like the best option.

@cmluciano

This comment has been minimized.

Copy link
Collaborator Author

commented Feb 26, 2015

Closed via #223

@cmluciano cmluciano closed this Feb 26, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.