Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

policy provider prevents updating an existing policy #424

Closed
brendenyule opened this issue Mar 30, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@brendenyule
Copy link

commented Mar 30, 2017

The set action in policy provider prevents a policy from being set if it already exists.
I think expected behavior would be to let the policy be updated if it already exists.

rabbitmqctl set_policy is already an idempotent command and handles this out of the box.

Casual proof the rabbitmq set_policy is idempotent:

user@ip:~$ sudo rabbitmqctl list_policies
Listing policies ...
/	mps-ha-all	all	^	{"ha-mode":"all"}	0

user@ip:~$ sudo rabbitmqctl set_policy mps-ha-all "^" '{"ha-mode":"all"}' --priority 0
Setting policy "mps-ha-all" for pattern "^" to "{\"ha-mode\":\"all\"}" with priority "0" ...

user@ip:~$ sudo rabbitmqctl list_policies
Listing policies ...
/	mps-ha-all	all	^	{"ha-mode":"all"}	0
@michaelklishin

This comment has been minimized.

Copy link
Member

commented Mar 30, 2017

Should be fixed in #425, thank you.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.