Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fixed 'rabbitmqctl eval' command for old rabbitmq versions #272

Merged
merged 1 commit into from Jun 16, 2015

Conversation

@XiangYao
Copy link

commented May 27, 2015

This is a known issue in rabbitmq 3.3.4 or earlier, and the rabbitmqctl commands always appends ...done. at the end of outputs, which causes issues in cluster.rb when doing join to the cluster.
Please refer to my issue for details: #271

This fix force the command rabbitmqctl eval "node()." to always print out the first line which filters out the wrong tail string.

Before

[root@prod-rabbitmq-1001 ~]# rabbitmqctl eval "node()."
'rabbit@prod-rabbitmq-1001'
...done.

After

[root@prod-rabbitmq-1001 ~]# rabbitmqctl eval "node()." | head -1
'rabbit@prod-rabbitmq-1001'

I've tested this PR in the latest rabbitmq 3.5.3 and old versions like 3.3.4 and 3.2.3, and everything looks fine.

Thanks!

@michaelklishin

This comment has been minimized.

Copy link
Member

commented May 27, 2015

👍

jjasghar pushed a commit that referenced this pull request Jun 16, 2015
JJ Asghar
Merge pull request #272 from XiangYao/NO-REF
Fixed 'rabbitmqctl eval' command for old rabbitmq versions

@jjasghar jjasghar merged commit 2a425bd into rabbitmq:master Jun 16, 2015

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.