Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Umbrella issue: "upgrade" license to Mozilla Public License 2.0 #2372

Closed
michaelklishin opened this issue Jun 9, 2020 · 2 comments
Closed
Milestone

Comments

@michaelklishin
Copy link
Member

michaelklishin commented Jun 9, 2020

This is an umbrella issue not specific to this repository.

Our team has been given a green light to migrate to Mozilla Public License 2.0.

The migration will benefit RabbitMQ in several ways:

  • We won't be using a license that is considered to be "obsolete" and "obscure" by some current and prospective users
  • In general, the core team will have to answer fewer licensing-related questions and spend more time developing RabbitMQ
  • MPL2 explicitly mentions GPL, BSD and ASL2 compatibility (see Q13 and Q14 in [1]), while with MPL 1.1 we had to double- or triple-license our client libraries to eliminate potential compatibility confusion
  • MPL2 is arguably easier to reason about than 1.1
  1. https://www.mozilla.org/en-US/MPL/2.0/FAQ/
@michaelklishin
Copy link
Member Author

michaelklishin commented Jun 9, 2020

Relevant links:

@ArgTang
Copy link

ArgTang commented Jul 14, 2020

#2408

@michaelklishin michaelklishin added this to the 3.8.6 milestone Jul 26, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

2 participants