Skip to content
Permalink
Browse files

Drop support for Ruby 2.2 as it is well past EOL.

  • Loading branch information
ioquatix committed Jan 11, 2020
1 parent eacc84c commit d81a5d3bdd20d80527164705b1fcfd0b7f4be6cd
Showing with 1 addition and 12 deletions.
  1. +0 −11 .circleci/config.yml
  2. +1 −1 rack.gemspec
@@ -4,7 +4,6 @@ workflows:
test:
jobs:
- test-jruby
- test-ruby-2.2
- test-ruby-2.3
- test-ruby-2.4
- test-ruby-2.5
@@ -35,16 +34,6 @@ default-steps: &default-steps
- run: bundle exec rake ci

jobs:
test-ruby-2.2:
docker:
- image: circleci/ruby:2.2
# Spawn a process owned by root
# This works around an issue explained here:
# https://github.com/circleci/circleci-images/pull/132
command: sudo /bin/sh
- image: memcached:1.4
steps: *default-steps

test-ruby-2.3:
docker:
- image: circleci/ruby:2.3
@@ -27,7 +27,7 @@ EOF
s.author = 'Leah Neukirchen'
s.email = 'leah@vuxu.org'
s.homepage = 'https://rack.github.io/'
s.required_ruby_version = '>= 2.2.2'
s.required_ruby_version = '>= 2.3.0'
s.metadata = {
"bug_tracker_uri" => "https://github.com/rack/rack/issues",
"changelog_uri" => "https://github.com/rack/rack/blob/master/CHANGELOG.md",

0 comments on commit d81a5d3

Please sign in to comment.
You can’t perform that action at this time.