Skip to content
This repository

Try to use taps with version 1.5.2 and you will get #528

Closed
boriscy opened this Issue March 14, 2013 · 3 comments

4 participants

Boris Barroso James Tucker steve fox Вольдэмар Дулецкий
Boris Barroso

I receive this error when I use rack 1.5.2 on Ruby 1.9.3
ERROR: Rack::Utils::OkJson::Error: cannot encode Symbol: :admins
An error occurred but Hoptoad was not notified. To use Hoptoad, please
install the 'hoptoad_notifier' gem and set ENV["HOPTOAD_API_KEY"]
127.0.0.1 - demo [14/Mar/2013 14:48:21] "GET /sessions/2188167879/pull/table_names HTTP/1.1" 500 - 0.0145
Rack::Utils::OkJson::Error - cannot encode Symbol: :admins:

But everything works with rack 1.5.0

steve fox

Same issue here

ERROR: Rack::Utils::OkJson::Error: cannot encode Symbol: :brands

I tried installing rack 1.5.0, but get

-<%>- bundle update rack
Fetching source index for http://rubygems.org/
Fetching source index for http://gemcutter.org/
Bundler could not find compatible versions for gem "rack":
In Gemfile:
rails (= 3.2.11) depends on
rack (~> 1.4.0)

rack (1.5.0)

gem install --version '1.5.0' rack

succeeds, but I still can't run taps pull without getting that same error.

James Tucker
Owner
raggi commented April 21, 2013

Insufficient information for debugging. Looks like a bug in taps.

James Tucker raggi closed this April 21, 2013
Вольдэмар Дулецкий

the same problem

Rack::Utils::OkJson::Error - cannot encode Symbol: :crop_versions:
 /usr/local/rvm/gems/ruby-1.9.3-p448@xxx/gems/rack-1.5.2/lib/rack/utils/okjson.rb:427:in `valenc'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.