Don't load the backport for uri/common.rb when running 1.9.3-p125 and beyond #358

Merged
merged 1 commit into from Mar 5, 2012
View
2 lib/rack/utils.rb
@@ -10,7 +10,7 @@
require 'rack/backports/uri/common_18'
elsif major == 1 && minor == 9 && patch < 3
require 'rack/backports/uri/common_192'
-elsif major == 1 && minor == 9 && patch == 3
+elsif major == 1 && minor == 9 && patch == 3 && RUBY_PATCHLEVEL < 125
require 'rack/backports/uri/common_193'
else
require 'uri/common'