Use to_enum instead of Enumerator.new to remove Ruby 2.0 warnings #475

Merged
merged 1 commit into from Dec 29, 2012

Conversation

Projects
None yet
3 participants
Member

spastorino commented Dec 29, 2012

This commit avoid warn message
Enumerator.new without a block is deprecated; use Object#to_enum

Use to_enum instead of Enumerator.new to remove Ruby 2.0 warnings
This commit avoid warn message
Enumerator.new without a block is deprecated; use Object#to_enum

rkh added a commit that referenced this pull request Dec 29, 2012

Merge pull request #475 from spastorino/remove_2_0_warns
Use to_enum instead of Enumerator.new to remove Ruby 2.0 warnings

@rkh rkh merged commit 285cc67 into rack:master Dec 29, 2012

1 check was pending

default The Travis build is in progress
Details
Owner

raggi commented Dec 29, 2012

Officially no more 1.8.6 👍

Member

spastorino commented Dec 29, 2012

@raggi yeah I was aware that master wasn't supporting 1.8.6 ❤️

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment