Permalink
Browse files

PHP Warnings under WP 4.7 / Parameter 1 to FeedWordPressHTTPAuthentic…

…ator::set_auth_options() expected to be a reference, value given in [...]/wp-includes/class-wp-hook.php on line 30 / new call to http_api_curl hook in WP4.7 inconsistent about use of ampersands; don't require an amped reference parameter for the curl handle here.
  • Loading branch information...
1 parent 0c5336a commit 7fa77d4816d32e4cb0664e86900a42ab4ca87eea Rad Geek committed Dec 10, 2016
Showing with 2 additions and 2 deletions.
  1. +2 −2 feedwordpresshttpauthenticator.class.php
@@ -9,7 +9,7 @@ function __construct () {
endforeach;
add_filter('pre_http_request', array($this, 'pre_http_request'), 10, 3);
- add_action('http_api_curl', array($this, 'set_auth_options'), 1000, 1);
+ add_action('http_api_curl', array($this, 'set_auth_options'), 1000, 3);
} /* FeedWordPressHTTPAuthenticator::__construct () */
function methods_available () {
@@ -150,7 +150,7 @@ function if_curl ($use, $args, $what) {
return $use;
} /* FeedWordPressHTTPAuthenticator::if_curl () */
- function set_auth_options (&$handle) {
+ function set_auth_options ($handle, $r, $url) {
if ('digest'==$this->args['authentication']) :
curl_setopt($handle, CURLOPT_HTTPAUTH, CURLAUTH_DIGEST);
endif;

0 comments on commit 7fa77d4

Please sign in to comment.