./script/extension install fails for gem bundled extension #88

Closed
johnmuhl opened this Issue Feb 1, 2010 · 4 comments

Comments

Projects
None yet
1 participant
Owner

johnmuhl commented Feb 1, 2010

i removed git from my $PATH and removed the repository url from the registry http://ext.radiantcms.org/extensions/192-kramdown-filter leaving only the download url of the .gem bundle http://gemcutter.org/downloads/radiant-kramdown_filter-extension-1.0.5.gem

then ran ./script/extension install kramdown_filter and get the error http://gist.github.com/292124

Owner

johnmuhl commented Feb 8, 2010

./script/extension info kramdown_filter

Name:           kramdown_filter
Description:   ...
Author:          john muhl <email>
Source code:
Download:     http://gemcutter.org/downloads/radiant-kramdown_filter....gem
Install type:

maybe the error is that the registry does not return an install_type unless there is a repository_url ?

Owner

johnmuhl commented May 27, 2010

as suspected there are changes needed on the registry side to ensure an install_type comes back. now it looks like there are other problems on the script/extension side; i guess because the gem install part was written before there was such a thing :)

Owner

johnmuhl commented Jun 18, 2010

make basic gem installation work. closed by 7b0c3ae

@rx rx pushed a commit to voomify/radiant that referenced this issue Jul 19, 2011

@johnmuhl johnmuhl make basic gem installation work. closes #88 16787dc

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment