Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

No need to override to_yaml and yaml_initialize methods in ActiveReco…

…rd::Core
  • Loading branch information...
commit bdc49dcb4ee2af23599965e98fec1bfe21561c23 1 parent b65bdb1
@rafaelfranca authored
Showing with 0 additions and 20 deletions.
  1. +0 −20 activerecord/lib/active_record/core.rb
View
20 activerecord/lib/active_record/core.rb
@@ -317,26 +317,6 @@ def inspect
"#<#{self.class} #{inspection}>"
end
- # Hackery to accomodate Syck. Remove for 4.0.
- def to_yaml(opts = {}) #:nodoc:
- if !YAML::ENGINE.syck?
- super
- else
- coder = {}
- encode_with(coder)
- YAML.quick_emit(self, opts) do |out|
- out.map(taguri, to_yaml_style) do |map|
- coder.each { |k, v| map.add(k, v) }
- end
- end
- end
- end
-
- # Hackery to accomodate Syck. Remove for 4.0.
- def yaml_initialize(tag, coder) #:nodoc:
- init_with(coder)
- end
-
private
# Under Ruby 1.9, Array#flatten will call #to_ary (recursively) on each of the elements
Please sign in to comment.
Something went wrong with that request. Please try again.