Permalink
Browse files

fix dependency duplication

  • Loading branch information...
1 parent de97d06 commit c9c4332ac487d3a643f65bc51bd32daaaba0d5b2 @rafmagana committed Nov 15, 2010
Showing with 85 additions and 80 deletions.
  1. +10 −8 Gemfile
  2. +32 −14 Gemfile.lock
  3. +3 −13 Rakefile
  4. +40 −45 dooby.gemspec
View
18 Gemfile
@@ -1,15 +1,17 @@
source "http://rubygems.org"
group :development do
- gem "rspec", "~> 2.0.0"
- gem "bundler", "~> 1.0.0"
- gem "jeweler", "~> 1.5.0.pre5"
- gem "rcov", ">= 0"
+ gem "rspec", "2.0.0"
+ gem "cucumber", "0.9.3"
+ gem "aruba", "0.2.4"
+ gem "bundler", "1.0.0"
+ gem "jeweler", "1.5.0"
+ gem "rcov", "0.9.9"
end
-group :production do
- gem "main", "4.2.0"
- gem "colored", "1.2"
+group :runtime do
+ gem "main", "4.2.0"
+ gem "colored", "1.2"
gem "highline", "1.6.1"
- gem "chronic", "0.3.0"
+ gem "chronic", "0.3.0"
end
View
46 Gemfile.lock
@@ -2,41 +2,59 @@ GEM
remote: http://rubygems.org/
specs:
arrayfields (4.7.4)
+ aruba (0.2.4)
+ background_process
+ cucumber (~> 0.9.3)
+ background_process (1.2)
+ builder (2.1.2)
chronic (0.3.0)
colored (1.2)
+ cucumber (0.9.3)
+ builder (~> 2.1.2)
+ diff-lcs (~> 1.1.2)
+ gherkin (~> 2.2.9)
+ json (~> 1.4.6)
+ term-ansicolor (~> 1.0.5)
diff-lcs (1.1.2)
fattr (2.1.0)
+ gherkin (2.2.9)
+ json (~> 1.4.6)
+ term-ansicolor (~> 1.0.5)
git (1.2.5)
highline (1.6.1)
- jeweler (1.5.0.pre5)
+ jeweler (1.5.0)
bundler (~> 1.0.0)
git (>= 1.2.5)
rake
+ json (1.4.6)
main (4.2.0)
arrayfields (>= 4.7.4)
fattr (>= 2.1.0)
rake (0.8.7)
rcov (0.9.9)
- rspec (2.0.1)
- rspec-core (~> 2.0.1)
- rspec-expectations (~> 2.0.1)
- rspec-mocks (~> 2.0.1)
- rspec-core (2.0.1)
- rspec-expectations (2.0.1)
+ rspec (2.0.0)
+ rspec-core (= 2.0.0)
+ rspec-expectations (= 2.0.0)
+ rspec-mocks (= 2.0.0)
+ rspec-core (2.0.0)
+ rspec-expectations (2.0.0)
diff-lcs (>= 1.1.2)
- rspec-mocks (2.0.1)
- rspec-core (~> 2.0.1)
- rspec-expectations (~> 2.0.1)
+ rspec-mocks (2.0.0)
+ rspec-core (= 2.0.0)
+ rspec-expectations (= 2.0.0)
+ term-ansicolor (1.0.5)
PLATFORMS
ruby
DEPENDENCIES
- bundler (~> 1.0.0)
+ aruba (= 0.2.4)
+ bundler (= 1.0.0)
chronic (= 0.3.0)
colored (= 1.2)
+ cucumber (= 0.9.3)
highline (= 1.6.1)
- jeweler (~> 1.5.0.pre5)
+ jeweler (= 1.5.0)
main (= 4.2.0)
- rcov
- rspec (~> 2.0.0)
+ rcov (= 0.9.9)
+ rspec (= 2.0.0)
View
16 Rakefile
@@ -3,7 +3,7 @@ require 'rubygems'
require 'bundler'
begin
- Bundler.setup(:default, :development)
+ Bundler.setup(:development, :runtime)
rescue Bundler::BundlerError => e
$stderr.puts e.message
$stderr.puts "Run `bundle install` to install missing gems"
@@ -20,17 +20,8 @@ Jeweler::Tasks.new do |gem|
gem.email = "raf.magana@gmail.com"
gem.homepage = "http://github.com/rafmagana/dooby"
gem.authors = ["Rafael Magaña"]
-
- gem.add_runtime_dependency('main', ">= 4.2.0")
- gem.add_runtime_dependency('colored', ">= 1.2")
- gem.add_runtime_dependency('highline', ">= 1.6.1")
- gem.add_runtime_dependency('chronic', ">= 0.3.0")
-
- gem.add_development_dependency "rspec", ">= 2.0.1"
- gem.add_development_dependency "bundler", "~> 1.0.0"
- gem.add_development_dependency "jeweler", "~> 1.5.0.pre5"
- gem.add_development_dependency "rcov", ">= 0"
end
+
Jeweler::RubygemsDotOrgTasks.new
require 'rspec/core'
@@ -56,5 +47,4 @@ Rake::RDocTask.new do |rdoc|
rdoc.rdoc_files.include('lib/**/*.rb')
end
-task :bi => [:build, :install]
-
+task :bi => [:build, :install]
View
85 dooby.gemspec
@@ -1,6 +1,6 @@
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
+# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Rafael Maga\303\261a"]
- s.date = %q{2010-11-06}
+ s.date = %q{2010-11-15}
s.default_executable = %q{dooby}
s.description = %q{Handle your to-do/notes list through the command line}
s.email = %q{raf.magana@gmail.com}
@@ -30,6 +30,11 @@ Gem::Specification.new do |s|
"VERSION",
"bin/dooby",
"dooby.gemspec",
+ "features/adding_items.feature",
+ "features/deleting_items.feature",
+ "features/initialize_dooby.feature",
+ "features/step_definitions/dooby_steps.rb",
+ "features/support/env.rb",
"lib/dooby.rb",
"lib/dooby/base.rb",
"lib/dooby/cli_helper.rb",
@@ -43,67 +48,57 @@ Gem::Specification.new do |s|
"spec/dooby_module_spec.rb",
"spec/list_spec.rb",
"spec/spec_helper.rb",
- "spec/task_spec.rb",
- "test/helper.rb",
- "test/test_dooby.rb"
+ "spec/task_spec.rb"
]
s.homepage = %q{http://github.com/rafmagana/dooby}
s.require_paths = ["lib"]
s.rubygems_version = %q{1.3.7}
- s.summary = %q{A very simplistic command-line to-do list manager in Ruby}
+ s.summary = %q{A very simplistic command-line tag-driven to-do list manager in Ruby}
s.test_files = [
"spec/dooby_module_spec.rb",
"spec/list_spec.rb",
"spec/spec_helper.rb",
- "spec/task_spec.rb",
- "test/helper.rb",
- "test/test_dooby.rb"
+ "spec/task_spec.rb"
]
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<rspec>, ["~> 2.0.0"])
- s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.5.0.pre5"])
- s.add_development_dependency(%q<rcov>, [">= 0"])
- s.add_runtime_dependency(%q<main>, [">= 4.2.0"])
- s.add_runtime_dependency(%q<colored>, [">= 1.2"])
- s.add_runtime_dependency(%q<highline>, [">= 1.6.1"])
- s.add_runtime_dependency(%q<chronic>, [">= 0.3.0"])
- s.add_development_dependency(%q<rspec>, [">= 2.0.1"])
- s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.5.0.pre5"])
- s.add_development_dependency(%q<rcov>, [">= 0"])
+ s.add_runtime_dependency(%q<main>, ["= 4.2.0"])
+ s.add_runtime_dependency(%q<colored>, ["= 1.2"])
+ s.add_runtime_dependency(%q<highline>, ["= 1.6.1"])
+ s.add_runtime_dependency(%q<chronic>, ["= 0.3.0"])
+ s.add_development_dependency(%q<rspec>, ["= 2.0.0"])
+ s.add_development_dependency(%q<cucumber>, ["= 0.9.3"])
+ s.add_development_dependency(%q<aruba>, ["= 0.2.4"])
+ s.add_development_dependency(%q<bundler>, ["= 1.0.0"])
+ s.add_development_dependency(%q<jeweler>, ["= 1.5.0"])
+ s.add_development_dependency(%q<rcov>, ["= 0.9.9"])
else
- s.add_dependency(%q<rspec>, ["~> 2.0.0"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.5.0.pre5"])
- s.add_dependency(%q<rcov>, [">= 0"])
- s.add_dependency(%q<main>, [">= 4.2.0"])
- s.add_dependency(%q<colored>, [">= 1.2"])
- s.add_dependency(%q<highline>, [">= 1.6.1"])
- s.add_dependency(%q<chronic>, [">= 0.3.0"])
- s.add_dependency(%q<rspec>, [">= 2.0.1"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.5.0.pre5"])
- s.add_dependency(%q<rcov>, [">= 0"])
+ s.add_dependency(%q<main>, ["= 4.2.0"])
+ s.add_dependency(%q<colored>, ["= 1.2"])
+ s.add_dependency(%q<highline>, ["= 1.6.1"])
+ s.add_dependency(%q<chronic>, ["= 0.3.0"])
+ s.add_dependency(%q<rspec>, ["= 2.0.0"])
+ s.add_dependency(%q<cucumber>, ["= 0.9.3"])
+ s.add_dependency(%q<aruba>, ["= 0.2.4"])
+ s.add_dependency(%q<bundler>, ["= 1.0.0"])
+ s.add_dependency(%q<jeweler>, ["= 1.5.0"])
+ s.add_dependency(%q<rcov>, ["= 0.9.9"])
end
else
- s.add_dependency(%q<rspec>, ["~> 2.0.0"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.5.0.pre5"])
- s.add_dependency(%q<rcov>, [">= 0"])
- s.add_dependency(%q<main>, [">= 4.2.0"])
- s.add_dependency(%q<colored>, [">= 1.2"])
- s.add_dependency(%q<highline>, [">= 1.6.1"])
- s.add_dependency(%q<chronic>, [">= 0.3.0"])
- s.add_dependency(%q<rspec>, [">= 2.0.1"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.5.0.pre5"])
- s.add_dependency(%q<rcov>, [">= 0"])
+ s.add_dependency(%q<main>, ["= 4.2.0"])
+ s.add_dependency(%q<colored>, ["= 1.2"])
+ s.add_dependency(%q<highline>, ["= 1.6.1"])
+ s.add_dependency(%q<chronic>, ["= 0.3.0"])
+ s.add_dependency(%q<rspec>, ["= 2.0.0"])
+ s.add_dependency(%q<cucumber>, ["= 0.9.3"])
+ s.add_dependency(%q<aruba>, ["= 0.2.4"])
+ s.add_dependency(%q<bundler>, ["= 1.0.0"])
+ s.add_dependency(%q<jeweler>, ["= 1.5.0"])
+ s.add_dependency(%q<rcov>, ["= 0.9.9"])
end
end

0 comments on commit c9c4332

Please sign in to comment.