Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

0.9.0 release

  • Loading branch information...
commit c8b3a20e8bd71cbcd831174c71331b391e964c18 1 parent 0324732
@rtomayko rtomayko authored
Showing with 8 additions and 4 deletions.
  1. +5 −1 CHANGES
  2. +1 −1  lib/sinatra/base.rb
  3. +2 −2 sinatra.gemspec
View
6 CHANGES
@@ -1,4 +1,4 @@
-= 0.9.0 (unreleased)
+= 0.9.0 / 2009-01-18
* Works with and requires Rack >= 0.9.1
@@ -45,6 +45,10 @@
has the status code specified. It's also possible to register an error
page for a range of status codes: "error(500..599)".
+ * In-file templates are now automatically imported from the file that
+ requires 'sinatra'. The use_in_file_templates! method is still available
+ for loading templates from other files.
+
* Sinatra's testing support is no longer dependent on Test::Unit. Requiring
'sinatra/test' adds the Sinatra::Test module and Sinatra::TestHarness
class, which can be used with any test framework. The 'sinatra/test/unit',
View
2  lib/sinatra/base.rb
@@ -4,7 +4,7 @@
require 'rack/builder'
module Sinatra
- VERSION = '0.8.10'
+ VERSION = '0.9.0'
class Request < Rack::Request
def user_agent
View
4 sinatra.gemspec
@@ -3,8 +3,8 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.name = 'sinatra'
- s.version = '0.8.10'
- s.date = '2009-01-16'
+ s.version = '0.9.0'
+ s.date = '2009-01-18'
s.description = "Classy web-development dressed in a DSL"
s.summary = "Classy web-development dressed in a DSL"
Please sign in to comment.
Something went wrong with that request. Please try again.