Permalink
Browse files

Removed overriden HashWithIndifferentAccess#convert_value. Updated Ge…

…m versions. Updated ruby-version.
1 parent a725c3c commit 00550f2aaf7a427c9bc4db7b97d98caaec5162f2 Rahmal Conda committed Aug 22, 2016
Showing with 26 additions and 41 deletions.
  1. +1 −1 .ruby-version
  2. +1 −0 ChangeLog
  3. +5 −2 Gemfile
  4. +11 −22 Gemfile.lock
  5. +0 −7 lib/rconfig/config.rb
  6. +8 −9 rconfig.gemspec
View
2 .ruby-version
@@ -1 +1 @@
-ruby-2.1.5
+2.1.5
View
1 ChangeLog
@@ -3,6 +3,7 @@
* Added support for windows paths
* Updated tests specs so that they can run on windows
* Updated gem dependencies so thay can install on ruby 2.2.x
+* Removed overriden HashWithIndifferentAccess#convert_value.
0.5.3
=====
View
7 Gemfile
@@ -1,10 +1,13 @@
source 'http://rubygems.org'
-gem 'activesupport', '> 3.0', :require => 'active_support'
+gem 'activesupport', '~> 3.2', require: 'active_support'
@Th33x1l3
Th33x1l3 Aug 23, 2016

Why have you locked active support gem to release 3.2.x?
it has a I18n issue.

+gem 'json', '> 1.8.1'
group :development do
+ gem 'rake', '~> 11.2'
+ gem 'rack', '~> 1.4.2'
gem 'rspec', '> 2.3.0'
gem 'bundler', '> 1.0.0'
gem 'jeweler', '> 1.6.4'
- gem 'i18n', '> 0.6.0'
+ gem 'i18n'
end
View
33 Gemfile.lock
@@ -1,14 +1,11 @@
GEM
remote: http://rubygems.org/
specs:
- activesupport (5.0.0.1)
- concurrent-ruby (~> 1.0, >= 1.0.2)
- i18n (~> 0.7)
- minitest (~> 5.1)
- tzinfo (~> 1.1)
+ activesupport (3.2.22.4)
+ i18n (~> 0.6, >= 0.6.4)
+ multi_json (~> 1.0)
addressable (2.4.0)
builder (3.2.2)
- concurrent-ruby (1.0.2)
descendants_tracker (0.0.4)
thread_safe (~> 0.3, >= 0.3.1)
diff-lcs (1.2.5)
@@ -34,30 +31,25 @@ GEM
rake
rdoc
semver
- json (1.8.3)
+ json (2.0.2)
jwt (1.5.4)
mini_portile2 (2.1.0)
- minitest (5.9.0)
multi_json (1.12.1)
multi_xml (0.5.5)
multipart-post (2.0.0)
nokogiri (1.6.8)
mini_portile2 (~> 2.1.0)
pkg-config (~> 1.1.7)
- nokogiri (1.6.8-x64-mingw32)
- mini_portile2 (~> 2.1.0)
- pkg-config (~> 1.1.7)
oauth2 (1.2.0)
faraday (>= 0.8, < 0.10)
jwt (~> 1.0)
multi_json (~> 1.3)
multi_xml (~> 0.5)
rack (>= 1.2, < 3)
pkg-config (1.1.7)
- rack (2.0.1)
+ rack (1.4.7)
rake (11.2.2)
- rdoc (4.2.2)
- json (~> 1.4)
+ rdoc (4.1.0)
rspec (3.5.0)
rspec-core (~> 3.5.0)
rspec-expectations (~> 3.5.0)
@@ -73,19 +65,16 @@ GEM
rspec-support (3.5.0)
semver (1.0.1)
thread_safe (0.3.5)
- tzinfo (1.2.2)
- thread_safe (~> 0.1)
PLATFORMS
ruby
- x64-mingw32
DEPENDENCIES
- activesupport (> 3.0)
+ activesupport (~> 3.2)
bundler (> 1.0.0)
- i18n (> 0.6.0)
+ i18n
jeweler (> 1.6.4)
+ json (> 1.8.1)
+ rack (~> 1.4.2)
+ rake (~> 11.2)
rspec (> 2.3.0)
-
-BUNDLED WITH
- 1.12.5
View
7 lib/rconfig/config.rb
@@ -76,12 +76,5 @@ def default(key = self.default_key)
protected
- ##
- # Override HashWithIndifferentAccess#convert_value
- # return instance of Config for Hash values.
- def convert_value(value, options = {})
- value.is_a?(Hash) ? self.class.new(value).freeze : super
- end
-
end # class Config
end
View
17 rconfig.gemspec
@@ -24,16 +24,15 @@ Gem::Specification.new do |s|
s.require_paths = ['lib']
# Dependencies
- s.add_dependency 'activesupport', '> 3.0'
+ s.add_dependency 'activesupport', '~> 3.2'
+ s.add_dependency 'json', '> 1.8.1'
# Development Dependencies
- s.add_development_dependency 'rspec', '> 2.3.0'
- s.add_development_dependency 'bundler', '> 1.0.0'
- s.add_development_dependency 'jeweler', '> 1.6.4'
- s.add_development_dependency 'i18n'
- ## json 1.8.1 has a error in native extension that makes it impossible to install with
- ## ruby 2.2.x, so we have to force it to be greater than that
- ## check https://github.com/flori/json/issues/229 for the issue
- s.add_development_dependency 'json', '> 1.8.1'
+ s.add_development_dependency 'rake', '~> 11.2'
+ s.add_development_dependency 'rack', '~> 1.4.2'
+ s.add_development_dependency 'rspec', '> 2.3.0'
+ s.add_development_dependency 'bundler', '> 1.0.0'
+ s.add_development_dependency 'jeweler', '> 1.6.4'
+ s.add_development_dependency 'i18n'
end

0 comments on commit 00550f2

Please sign in to comment.