Permalink
Browse files

Update to rails 3.1 release.

  • Loading branch information...
1 parent 5bec15d commit 418a13892210685e078e9572d31d9c9105811dfc @metaskills metaskills committed Sep 1, 2011
Showing with 83 additions and 90 deletions.
  1. +1 −0 .gitignore
  2. +3 −5 Gemfile
  3. +70 −82 Gemfile.lock
  4. +9 −3 config/application.rb
View
@@ -4,3 +4,4 @@ db/*structure.sql
log/*.log
tmp/
.rvmrc
+.rbenv-version
View
@@ -1,13 +1,11 @@
source 'http://rubygems.org'
-# gem 'rails', '~> 3.1.0'
-gem 'rails', :git => 'git://github.com/rails/rails.git', :branch => '3-1-stable'
+gem 'rails', '~> 3.1.0'
gem 'tiny_tds', '~> 0.4.5'
-# gem 'activerecord-sqlserver-adapter'
-gem 'activerecord-sqlserver-adapter', :git => 'git://github.com/rails-sqlserver/activerecord-sqlserver-adapter.git'
+gem 'activerecord-sqlserver-adapter', '~> 3.1.0'
-gem 'sass-rails', "~> 3.1.0.rc"
+gem 'sass-rails'
gem 'coffee-script'
gem 'uglifier'
gem 'jquery-rails'
View
@@ -1,78 +1,51 @@
-GIT
- remote: git://github.com/rails-sqlserver/activerecord-sqlserver-adapter.git
- revision: b7afcc7e142f365062f771c520cc8fc752b44115
- specs:
- activerecord-sqlserver-adapter (3.1.0.rc2)
- activerecord (~> 3.1.0.rc1)
-
-GIT
- remote: git://github.com/rails/rails.git
- revision: 391b3739864c5cf8ba7b792cad27dd023a1f2db2
- branch: 3-1-stable
+GEM
+ remote: http://rubygems.org/
specs:
- actionmailer (3.1.0.rc4)
- actionpack (= 3.1.0.rc4)
+ actionmailer (3.1.0)
+ actionpack (= 3.1.0)
mail (~> 2.3.0)
- actionpack (3.1.0.rc4)
- activemodel (= 3.1.0.rc4)
- activesupport (= 3.1.0.rc4)
+ actionpack (3.1.0)
+ activemodel (= 3.1.0)
+ activesupport (= 3.1.0)
builder (~> 3.0.0)
erubis (~> 2.7.0)
i18n (~> 0.6)
- rack (~> 1.3.0)
- rack-cache (~> 1.0.1)
- rack-mount (~> 0.8.1)
- rack-test (~> 0.6.0)
- sprockets (~> 2.0.0.beta.10)
- tzinfo (~> 0.3.27)
- activemodel (3.1.0.rc4)
- activesupport (= 3.1.0.rc4)
- bcrypt-ruby (~> 2.1.4)
+ rack (~> 1.3.2)
+ rack-cache (~> 1.0.3)
+ rack-mount (~> 0.8.2)
+ rack-test (~> 0.6.1)
+ sprockets (~> 2.0.0)
+ activemodel (3.1.0)
+ activesupport (= 3.1.0)
+ bcrypt-ruby (~> 3.0.0)
builder (~> 3.0.0)
i18n (~> 0.6)
- activerecord (3.1.0.rc4)
- activemodel (= 3.1.0.rc4)
- activesupport (= 3.1.0.rc4)
- arel (~> 2.1.1)
- tzinfo (~> 0.3.27)
- activeresource (3.1.0.rc4)
- activemodel (= 3.1.0.rc4)
- activesupport (= 3.1.0.rc4)
- activesupport (3.1.0.rc4)
+ activerecord (3.1.0)
+ activemodel (= 3.1.0)
+ activesupport (= 3.1.0)
+ arel (~> 2.2.1)
+ tzinfo (~> 0.3.29)
+ activerecord-sqlserver-adapter (3.1.0.0)
+ activerecord (~> 3.1.0)
+ activeresource (3.1.0)
+ activemodel (= 3.1.0)
+ activesupport (= 3.1.0)
+ activesupport (3.1.0)
multi_json (~> 1.0)
- rails (3.1.0.rc4)
- actionmailer (= 3.1.0.rc4)
- actionpack (= 3.1.0.rc4)
- activerecord (= 3.1.0.rc4)
- activeresource (= 3.1.0.rc4)
- activesupport (= 3.1.0.rc4)
- bundler (~> 1.0)
- railties (= 3.1.0.rc4)
- railties (3.1.0.rc4)
- actionpack (= 3.1.0.rc4)
- activesupport (= 3.1.0.rc4)
- rack-ssl (~> 1.3.2)
- rake (>= 0.8.7)
- rdoc (~> 3.4)
- thor (~> 0.14.6)
-
-GEM
- remote: http://rubygems.org/
- specs:
- ansi (1.2.5)
- arel (2.1.1)
- bcrypt-ruby (2.1.4)
+ ansi (1.3.0)
+ arel (2.2.1)
+ bcrypt-ruby (3.0.0)
builder (3.0.0)
coffee-script (2.2.0)
coffee-script-source
execjs
- coffee-script-source (1.1.1)
+ coffee-script-source (1.1.2)
erubis (2.7.0)
- execjs (1.1.3)
+ execjs (1.2.4)
multi_json (~> 1.0)
- hike (1.1.0)
+ hike (1.2.1)
i18n (0.6.0)
- jquery-rails (1.0.11)
+ jquery-rails (1.0.13)
railties (~> 3.0)
thor (~> 0.14)
mail (2.3.0)
@@ -81,49 +54,64 @@ GEM
treetop (~> 1.4.8)
mime-types (1.16)
multi_json (1.0.3)
- polyglot (0.3.1)
- rack (1.3.0)
- rack-cache (1.0.2)
+ polyglot (0.3.2)
+ rack (1.3.2)
+ rack-cache (1.0.3)
rack (>= 0.4)
- rack-mount (0.8.1)
+ rack-mount (0.8.3)
rack (>= 1.0.0)
rack-ssl (1.3.2)
rack
- rack-test (0.6.0)
+ rack-test (0.6.1)
rack (>= 1.0)
+ rails (3.1.0)
+ actionmailer (= 3.1.0)
+ actionpack (= 3.1.0)
+ activerecord (= 3.1.0)
+ activeresource (= 3.1.0)
+ activesupport (= 3.1.0)
+ bundler (~> 1.0)
+ railties (= 3.1.0)
+ railties (3.1.0)
+ actionpack (= 3.1.0)
+ activesupport (= 3.1.0)
+ rack-ssl (~> 1.3.2)
+ rake (>= 0.8.7)
+ rdoc (~> 3.4)
+ thor (~> 0.14.6)
rake (0.9.2)
- rdoc (3.6.1)
- sass (3.1.2)
- sass-rails (3.1.0.rc.2)
- actionpack (~> 3.1.0.rc1)
- railties (~> 3.1.0.rc1)
- sass (>= 3.1.2)
- sprockets (>= 2.0.0.beta.9)
- sprockets (2.0.0.beta.10)
- hike (~> 1.0)
+ rdoc (3.9.4)
+ sass (3.1.7)
+ sass-rails (3.1.0)
+ actionpack (~> 3.1.0)
+ railties (~> 3.1.0)
+ sass (>= 3.1.4)
+ sprockets (2.0.0)
+ hike (~> 1.2)
rack (~> 1.0)
- tilt (~> 1.1, != 1.3.0)
+ tilt (!= 1.3.0, ~> 1.1)
thor (0.14.6)
- tilt (1.3.2)
+ tilt (1.3.3)
tiny_tds (0.4.5)
- treetop (1.4.9)
+ treetop (1.4.10)
+ polyglot
polyglot (>= 0.3.1)
turn (0.8.2)
ansi (>= 1.2.2)
- tzinfo (0.3.28)
- uglifier (0.5.4)
+ tzinfo (0.3.29)
+ uglifier (1.0.2)
execjs (>= 0.3.0)
multi_json (>= 1.0.2)
PLATFORMS
ruby
DEPENDENCIES
- activerecord-sqlserver-adapter!
+ activerecord-sqlserver-adapter (~> 3.1.0)
coffee-script
jquery-rails
- rails!
- sass-rails (~> 3.1.0.rc)
+ rails (~> 3.1.0)
+ sass-rails
tiny_tds (~> 0.4.5)
turn
uglifier
View
@@ -2,9 +2,12 @@
require 'rails/all'
-# If you have a Gemfile, require the gems listed there, including any gems
-# you've limited to :test, :development, or :production.
-Bundler.require(:default, Rails.env) if defined?(Bundler)
+if defined?(Bundler)
+ # If you precompile assets before deploying to production, use this line
+ Bundler.require *Rails.groups(:assets => %w(development test))
+ # If you want your assets lazily compiled in production, use this line
+ # Bundler.require(:default, :assets, Rails.env)
+end
module AdventureWorks
class Application < Rails::Application
@@ -38,5 +41,8 @@ class Application < Rails::Application
# Enable the asset pipeline
config.assets.enabled = true
+
+ # Version of your assets, change this if you want to expire all your assets
+ config.assets.version = '1.0'
end
end

0 comments on commit 418a138

Please sign in to comment.