Permalink
Browse files

bumping to beta1

  • Loading branch information...
1 parent 80f11e3 commit 9798938927f3c43e02f79bdd825a42e28d105394 @tenderlove tenderlove committed Feb 25, 2013
Showing with 15 additions and 15 deletions.
  1. +14 −14 arel.gemspec
  2. +1 −1 lib/arel.rb
View
@@ -2,11 +2,11 @@
Gem::Specification.new do |s|
s.name = "arel"
- s.version = "3.0.2.20120819075748"
+ s.version = "4.0.0.beta1.20130225132415"
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Aaron Patterson", "Bryan Halmkamp", "Emilio Tagua", "Nick Kallen"]
- s.date = "2012-08-19"
+ s.date = "2013-02-25"
s.description = "Arel is a SQL AST manager for Ruby. It\n\n1. Simplifies the generation of complex SQL queries\n2. Adapts to various RDBMS systems\n\nIt is intended to be a framework framework; that is, you can build your own ORM\nwith it, focusing on innovative object and collection modeling as opposed to\ndatabase compatibility and query generation."
s.email = ["aaron@tenderlovemaking.com", "bryan@brynary.com", "miloops@gmail.com", "nick@example.org"]
s.extra_rdoc_files = ["History.txt", "MIT-LICENSE.txt", "Manifest.txt", "README.markdown"]
@@ -15,25 +15,25 @@ Gem::Specification.new do |s|
s.rdoc_options = ["--main", "README.markdown"]
s.require_paths = ["lib"]
s.rubyforge_project = "arel"
- s.rubygems_version = "1.8.24"
+ s.rubygems_version = "2.0.0"
s.summary = "Arel is a SQL AST manager for Ruby"
s.test_files = ["test/attributes/test_attribute.rb", "test/nodes/test_and.rb", "test/nodes/test_as.rb", "test/nodes/test_ascending.rb", "test/nodes/test_bin.rb", "test/nodes/test_count.rb", "test/nodes/test_delete_statement.rb", "test/nodes/test_descending.rb", "test/nodes/test_distinct.rb", "test/nodes/test_equality.rb", "test/nodes/test_extract.rb", "test/nodes/test_false.rb", "test/nodes/test_grouping.rb", "test/nodes/test_infix_operation.rb", "test/nodes/test_insert_statement.rb", "test/nodes/test_named_function.rb", "test/nodes/test_node.rb", "test/nodes/test_not.rb", "test/nodes/test_or.rb", "test/nodes/test_over.rb", "test/nodes/test_select_core.rb", "test/nodes/test_select_statement.rb", "test/nodes/test_sql_literal.rb", "test/nodes/test_sum.rb", "test/nodes/test_table_alias.rb", "test/nodes/test_true.rb", "test/nodes/test_update_statement.rb", "test/nodes/test_window.rb", "test/test_activerecord_compat.rb", "test/test_attributes.rb", "test/test_crud.rb", "test/test_delete_manager.rb", "test/test_factory_methods.rb", "test/test_insert_manager.rb", "test/test_select_manager.rb", "test/test_table.rb", "test/test_update_manager.rb", "test/visitors/test_bind_visitor.rb", "test/visitors/test_depth_first.rb", "test/visitors/test_dot.rb", "test/visitors/test_ibm_db.rb", "test/visitors/test_informix.rb", "test/visitors/test_join_sql.rb", "test/visitors/test_mssql.rb", "test/visitors/test_mysql.rb", "test/visitors/test_oracle.rb", "test/visitors/test_postgres.rb", "test/visitors/test_sqlite.rb", "test/visitors/test_to_sql.rb"]
if s.respond_to? :specification_version then
- s.specification_version = 3
+ s.specification_version = 4
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<minitest>, ["~> 4.3.3"])
- s.add_development_dependency(%q<rdoc>, ["~> 3.12"])
- s.add_development_dependency(%q<hoe>, ["~> 3.3.1"])
+ s.add_development_dependency(%q<minitest>, ["~> 4.6"])
+ s.add_development_dependency(%q<rdoc>, ["~> 3.10"])
+ s.add_development_dependency(%q<hoe>, ["~> 3.5"])
else
- s.add_dependency(%q<minitest>, ["~> 4.3.3"])
- s.add_dependency(%q<rdoc>, ["~> 3.12"])
- s.add_dependency(%q<hoe>, ["~> 3.3.1"])
+ s.add_dependency(%q<minitest>, ["~> 4.6"])
+ s.add_dependency(%q<rdoc>, ["~> 3.10"])
+ s.add_dependency(%q<hoe>, ["~> 3.5"])
end
else
- s.add_dependency(%q<minitest>, ["~> 4.3.3"])
- s.add_dependency(%q<rdoc>, ["~> 3.12"])
- s.add_dependency(%q<hoe>, ["~> 3.3.1"])
+ s.add_dependency(%q<minitest>, ["~> 4.6"])
+ s.add_dependency(%q<rdoc>, ["~> 3.10"])
+ s.add_dependency(%q<hoe>, ["~> 3.5"])
end
end
View
@@ -32,7 +32,7 @@
####
module Arel
- VERSION = '3.0.2'
+ VERSION = '4.0.0.beta1'
def self.sql raw_sql
Arel::Nodes::SqlLiteral.new raw_sql

0 comments on commit 9798938

Please sign in to comment.