Skip to content
Browse files

Remove explicit rubygems require. Use Active Support provided by Acti…

…ve Record. Add self to load path after requiring Active Record.
  • Loading branch information...
1 parent 32af162 commit a727cef713c75875941f56fc1e3779216c93d539 @jeremy jeremy committed Sep 14, 2009
Showing with 1 addition and 7 deletions.
  1. +1 −7 lib/arel.rb
View
8 lib/arel.rb
@@ -1,13 +1,7 @@
-$LOAD_PATH.unshift(File.dirname(__FILE__))
-
-require 'rubygems'
-require 'active_support'
-require 'active_support/dependencies'
-require 'active_support/core_ext/class/attribute_accessors'
-require 'active_support/core_ext/module/delegation'
require 'active_record'
require 'active_record/connection_adapters/abstract/quoting'
+$LOAD_PATH.unshift(File.dirname(__FILE__))
require 'arel/algebra'
require 'arel/engines'
require 'arel/session'

0 comments on commit a727cef

Please sign in to comment.
Something went wrong with that request. Please try again.