Permalink
Browse files

updating Rakefile with development dependencies

  • Loading branch information...
1 parent b9e83c9 commit e958eb8a3aece884f5302d99fae5305105e9d43a @tenderlove tenderlove committed Sep 24, 2010
Showing with 6 additions and 2 deletions.
  1. +2 −1 Rakefile
  2. +4 −1 arel.gemspec
View
@@ -2,7 +2,7 @@ require "rubygems"
gem 'hoe', '>= 2.1.0'
require 'hoe'
-Hoe.plugin :gemspec # install hoe-gemspec
+Hoe.plugin :gemspec # `gem install hoe-gemspec`
Hoe.spec 'arel' do
developer('Aaron Patterson', 'aaron@tenderlovemaking.com')
@@ -12,6 +12,7 @@ Hoe.spec 'arel' do
self.readme_file = 'README.markdown'
self.extra_rdoc_files = FileList['README.markdown']
+ self.extra_dev_deps << ['rspec', '~> 1.3.0']
self.testlib = :rspec
end
View
@@ -2,7 +2,7 @@
Gem::Specification.new do |s|
s.name = %q{arel}
- s.version = "1.0.1.beta.1.20100924164427"
+ s.version = "1.0.1.beta.1.20100924164615"
s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Aaron Patterson", "Bryan Halmkamp", "Emilio Tagua", "Nick Kallen"]
@@ -24,13 +24,16 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_development_dependency(%q<rubyforge>, [">= 2.0.4"])
+ s.add_development_dependency(%q<rspec>, ["~> 1.3.0"])
s.add_development_dependency(%q<hoe>, [">= 2.6.0"])
else
s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
+ s.add_dependency(%q<rspec>, ["~> 1.3.0"])
s.add_dependency(%q<hoe>, [">= 2.6.0"])
end
else
s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
+ s.add_dependency(%q<rspec>, ["~> 1.3.0"])
s.add_dependency(%q<hoe>, [">= 2.6.0"])
end
end

0 comments on commit e958eb8

Please sign in to comment.