Skip to content
Browse files

Fix test which depends on the RUBY_VERSION when using sqlite3 adapter.

  • Loading branch information...
1 parent 0c2930c commit f37c4a4d690888aa5cf8e54c8b404dd10f219f46 @miloops miloops committed Feb 17, 2010
Showing with 5 additions and 1 deletion.
  1. +5 −1 spec/arel/engines/sql/unit/predicates/in_spec.rb
View
6 spec/arel/engines/sql/unit/predicates/in_spec.rb
@@ -99,7 +99,11 @@ module Predicates
end
adapter_is :sqlite3 do
- sql.should be_like(%Q{"developers"."created_at" BETWEEN '2010-01-01 00:00:00' AND '2010-02-01 00:00:00'})
+ if RUBY_VERSION < '1.9'
+ sql.should be_like(%Q{"developers"."created_at" BETWEEN '2010-01-01 00:00:00.000000' AND '2010-02-01 00:00:00.000000'})
+ else
+ sql.should be_like(%Q{"developers"."created_at" BETWEEN '2010-01-01 00:00:00' AND '2010-02-01 00:00:00'})
+ end
end
adapter_is :postgresql do

0 comments on commit f37c4a4

Please sign in to comment.
Something went wrong with that request. Please try again.