Remove deprecated Relation module #113

Merged
merged 1 commit into from Mar 27, 2012
View
@@ -12,8 +12,6 @@
require 'arel/compatibility/wheres'
#### these are deprecated
-# The Arel::Relation constant is referenced in Rails
-require 'arel/relation'
require 'arel/expression'
####
@@ -1,6 +0,0 @@
-module Arel
- ###
- # This is deprecated. Fix rails, then remove this.
- module Relation
- end
-end
@@ -1,7 +1,5 @@
module Arel
class TreeManager
- # FIXME: Remove this.
- include Arel::Relation
include Arel::FactoryMethods
attr_reader :ast, :engine