Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 90 lines (73 sloc) 1.988 kb
ef8c2a8 @dasch Also use double quotes for #source
dasch authored
1 source "http://rubygems.org"
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
2
4eb0d58 @drogus Use gemspec instead of gem rails in Gemfile
drogus authored
3 gemspec
4
13df581 @tenderlove using AREL from the environment if it exists
tenderlove authored
5 if ENV['AREL']
6 gem "arel", :path => ENV['AREL']
7 else
e14e696 @tenderlove fixing arel requirements for released arel
tenderlove authored
8 gem "arel", '~> 2.1.0'
13df581 @tenderlove using AREL from the environment if it exists
tenderlove authored
9 end
10
2fe70c1 @josevalim Booya, sprockets now works from Engines.
josevalim authored
11 gem "coffee-script"
348b5b9 @arunagw Using sass directly as new version is out.
arunagw authored
12 gem "sass"
6d31224 @josevalim Ensure Set-Cookie is not set on assets.
josevalim authored
13 gem "uglifier", :git => "git://github.com/lautis/uglifier.git"
2b47059 @josh Add sprockets to Gemfile for testing
josh authored
14
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
15 gem "rake", ">= 0.8.7"
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
16 gem "mocha", ">= 0.9.8"
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of cla...
fxn authored
17
18 group :doc do
19 gem "rdoc", "~> 3.4"
20 gem "horo", "= 1.0.3"
b45a90f @tenderlove redcloth does not install on 1.9.3
tenderlove authored
21 gem "RedCloth", "~> 4.2" if RUBY_VERSION < "1.9.3"
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of cla...
fxn authored
22 end
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
23
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
24 # AS
25 gem "memcache-client", ">= 1.8.5"
26
27 platforms :mri_18 do
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored
28 gem "system_timer"
954359b @jonleighton Add Gemfile dependency for require_relative on mri18. This is a dependen...
jonleighton authored
29 # ruby-debug requires linecache which depends on require_relative but doesn't explicitly
30 # declare this in its gemspec
31 gem "require_relative"
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored
32 gem "ruby-debug", ">= 0.10.3"
2fe70c1 @josevalim Booya, sprockets now works from Engines.
josevalim authored
33 gem "json"
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored
34 end
35
29b54a4 @spastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored
36 platforms :mri_19 do
37 # TODO: Remove the conditional when ruby-debug19 supports Ruby >= 1.9.3
962936c @dasch Use quotes consistently in Gemfile
dasch authored
38 gem "ruby-debug19", :require => "ruby-debug" if RUBY_VERSION < "1.9.3"
29b54a4 @spastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored
39 end
40
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
41 platforms :ruby do
e06c448 @drogus Install rb-fsevent gem if ENV[RB_FSEVENT] is set
drogus authored
42 if ENV["RB_FSEVENT"]
962936c @dasch Use quotes consistently in Gemfile
dasch authored
43 gem "rb-fsevent"
e06c448 @drogus Install rb-fsevent gem if ENV[RB_FSEVENT] is set
drogus authored
44 end
962936c @dasch Use quotes consistently in Gemfile
dasch authored
45 gem "json"
46 gem "yajl-ruby"
171491b @gazay Change version of nokogiri gem
gazay authored
47 gem "nokogiri", ">= 1.4.5"
976a9d9 @arunagw Grouped the ruby-prof into test.
arunagw authored
48
49 group :test do
f2f63bf @spastorino ruby-prof doesn't work in 1.9.3
spastorino authored
50 gem "ruby-prof" if RUBY_VERSION < "1.9.3"
51
976a9d9 @arunagw Grouped the ruby-prof into test.
arunagw authored
52 end
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
53 # AR
421e06f @tenderlove updating gem dependency for sqlite3
tenderlove authored
54 gem "sqlite3", "~> 1.3.3"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
55
56 group :db do
fe4932b @tenderlove bumping the pg requirements
tenderlove authored
57 gem "pg", ">= 0.11.0"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
58 gem "mysql", ">= 2.8.1"
536e156 @arunagw Bump mysql2 to 0.3.5
arunagw authored
59 gem "mysql2", ">= 0.3.5"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
60 end
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
61 end
62
63 platforms :jruby do
64 gem "ruby-debug", ">= 0.10.3"
d1f10e7 @arunagw Test failing with Jruby "uninitialized constant TestJSONEncoding::JSON"
arunagw authored
65 gem "json"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
66 gem "activerecord-jdbcsqlite3-adapter"
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only de...
Yehuda Katz authored
67
ad13eb7 @spastorino Add a TODO to remove gem "jruby-openssl" when jruby-openssl is merge in ...
spastorino authored
68 # This is needed by now to let tests work on JRuby
69 # TODO: When the JRuby guys merge jruby-openssl in
70 # jruby this will be removed
ea30da3 @anildigital Add jruby-openssl gem in Gemfile necessary for JRuby
anildigital authored
71 gem "jruby-openssl"
72
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
73 group :db do
74 gem "activerecord-jdbcmysql-adapter"
75 gem "activerecord-jdbcpostgresql-adapter"
76 end
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only de...
Yehuda Katz authored
77 end
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Oracle...
rsim authored
78
79 # gems that are necessary for ActiveRecord tests with Oracle database
80 if ENV['ORACLE_ENHANCED_PATH'] || ENV['ORACLE_ENHANCED']
81 platforms :ruby do
962936c @dasch Use quotes consistently in Gemfile
dasch authored
82 gem "ruby-oci8", ">= 2.0.4"
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Oracle...
rsim authored
83 end
84 if ENV['ORACLE_ENHANCED_PATH']
962936c @dasch Use quotes consistently in Gemfile
dasch authored
85 gem "activerecord-oracle_enhanced-adapter", :path => ENV['ORACLE_ENHANCED_PATH']
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Oracle...
rsim authored
86 else
87 gem "activerecord-oracle_enhanced-adapter", :git => "git://github.com/rsim/oracle-enhanced.git"
88 end
89 end
Something went wrong with that request. Please try again.