Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 100 lines (81 sloc) 2.381 kB
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
1 source 'https://rubygems.org'
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
2
4eb0d58 @drogus Use gemspec instead of gem rails in Gemfile
drogus authored
3 gemspec
4
13df581 @tenderlove using AREL from the environment if it exists
tenderlove authored
5 if ENV['AREL']
17f2958 @drogus Use :github option in Gemfile and make hashes consistent
drogus authored
6 gem 'arel', path: ENV['AREL']
562583c @jonleighton Add ActiveRecord::Relation#uniq for toggling DISTINCT in the SQL query
jonleighton authored
7 else
b6105b0 @tenderlove updating arel and journey dependencies
tenderlove authored
8 gem 'arel'
13df581 @tenderlove using AREL from the environment if it exists
tenderlove authored
9 end
10
4903577 @spastorino Bump minitest to 3.2.0
spastorino authored
11 gem 'minitest', '~> 3.2.0'
709e432 @jeremy Rake is in 1.9 stdlib, no need for gem dep
jeremy authored
12 gem 'mocha', '>= 0.11.2'
17f2958 @drogus Use :github option in Gemfile and make hashes consistent
drogus authored
13 gem 'rack-test', github: "brynary/rack-test"
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
14 gem 'bcrypt-ruby', '~> 3.0.0'
15 gem 'jquery-rails'
5f0b37c @tenderlove Switching rack-mount to journey.
tenderlove authored
16
17 if ENV['JOURNEY']
17f2958 @drogus Use :github option in Gemfile and make hashes consistent
drogus authored
18 gem 'journey', path: ENV['JOURNEY']
5f0b37c @tenderlove Switching rack-mount to journey.
tenderlove authored
19 else
17f2958 @drogus Use :github option in Gemfile and make hashes consistent
drogus authored
20 gem 'journey', github: "rails/journey"
5f0b37c @tenderlove Switching rack-mount to journey.
tenderlove authored
21 end
22
dd2c9b9 @jonleighton add active_record_deprecated_finders as a dep
jonleighton authored
23 if ENV['AR_DEPRECATED_FINDERS']
24 gem 'active_record_deprecated_finders', path: ENV['AR_DEPRECATED_FINDERS']
25 else
17f2958 @drogus Use :github option in Gemfile and make hashes consistent
drogus authored
26 gem 'active_record_deprecated_finders', github: 'rails/active_record_deprecated_finders'
dd2c9b9 @jonleighton add active_record_deprecated_finders as a dep
jonleighton authored
27 end
28
2f6e389 @josevalim Make compressors lazily load.
josevalim authored
29 # This needs to be with require false to avoid
30 # it being automatically loaded by sprockets
17f2958 @drogus Use :github option in Gemfile and make hashes consistent
drogus authored
31 gem 'uglifier', '>= 1.0.3', require: false
2b47059 @josh Add sprockets to Gemfile for testing
josh authored
32
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of …
fxn authored
33 group :doc do
4936fc3 @fxn use our own fork of sdoc while Vijay's fix is not applied to voloko/sdoc
fxn authored
34 # The current sdoc cannot generate GitHub links due
35 # to a bug, but the PR that fixes it has been there
36 # for some weeks unapplied. As a temporary solution
37 # this is our own fork with the fix.
17f2958 @drogus Use :github option in Gemfile and make hashes consistent
drogus authored
38 gem 'sdoc', github: 'fxn/sdoc'
dbfc6b8 @fxn removes Ruby constraint in RedCloth dependency
fxn authored
39 gem 'RedCloth', '~> 4.2'
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
40 gem 'w3c_validators'
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of …
fxn authored
41 end
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
42
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
43 # AS
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
44 gem 'memcache-client', '>= 1.8.5'
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
45
a437986 @tenderlove allow people to set a local .Gemfile so that things like ruby-debug a…
tenderlove authored
46 # Add your own local bundler stuff
c4ceee8 @bogdan Fixed path to local gemfile.
bogdan authored
47 local_gemfile = File.dirname(__FILE__) + "/.Gemfile"
48 instance_eval File.read local_gemfile if File.exists? local_gemfile
29b54a4 @spastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored
49
74eb848 @zhengjia remove ruby-prof for rubinius in Gemfile
zhengjia authored
50 platforms :mri do
51 group :test do
91c26e8 @arunagw Fixed ruby-prof changes and let's use latest ruby-prof now.
arunagw authored
52 gem 'ruby-prof', '~> 0.11.2'
74eb848 @zhengjia remove ruby-prof for rubinius in Gemfile
zhengjia authored
53 end
54 end
55
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
56 platforms :ruby do
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
57 gem 'json'
58 gem 'yajl-ruby'
59 gem 'nokogiri', '>= 1.4.5'
976a9d9 @arunagw Grouped the ruby-prof into test.
arunagw authored
60
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
61 # AR
2fac915 @oscardelben Bumo sqlite3 gem
oscardelben authored
62 gem 'sqlite3', '~> 1.3.6'
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
63
64 group :db do
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
65 gem 'pg', '>= 0.11.0'
66 gem 'mysql', '>= 2.8.1'
67 gem 'mysql2', '>= 0.3.10'
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
68 end
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
69 end
70
71 platforms :jruby do
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
72 gem 'json'
73 gem 'activerecord-jdbcsqlite3-adapter', '>= 1.2.0'
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only…
Yehuda Katz authored
74
ad13eb7 @spastorino Add a TODO to remove gem "jruby-openssl" when jruby-openssl is merge …
spastorino authored
75 # This is needed by now to let tests work on JRuby
76 # TODO: When the JRuby guys merge jruby-openssl in
77 # jruby this will be removed
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
78 gem 'jruby-openssl'
ea30da3 @anildigital Add jruby-openssl gem in Gemfile necessary for JRuby
anildigital authored
79
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
80 group :db do
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
81 gem 'activerecord-jdbcmysql-adapter', '>= 1.2.0'
82 gem 'activerecord-jdbcpostgresql-adapter', '>= 1.2.0'
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
83 end
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only…
Yehuda Katz authored
84 end
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
85
86 # gems that are necessary for ActiveRecord tests with Oracle database
87 if ENV['ORACLE_ENHANCED_PATH'] || ENV['ORACLE_ENHANCED']
88 platforms :ruby do
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
89 gem 'ruby-oci8', '>= 2.0.4'
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
90 end
91 if ENV['ORACLE_ENHANCED_PATH']
17f2958 @drogus Use :github option in Gemfile and make hashes consistent
drogus authored
92 gem 'activerecord-oracle_enhanced-adapter', path: ENV['ORACLE_ENHANCED_PATH']
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
93 else
17f2958 @drogus Use :github option in Gemfile and make hashes consistent
drogus authored
94 gem 'activerecord-oracle_enhanced-adapter', github: 'rsim/oracle-enhanced'
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
95 end
96 end
b564ffc @yahonda To support ActiveRecord unit tests for IBM DB2
yahonda authored
97
8cc70cf @yahonda Fix typo in Rakefile
yahonda authored
98 # A gem necessary for ActiveRecord tests with IBM DB
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
99 gem 'ibm_db' if ENV['IBM_DB']
Something went wrong with that request. Please try again.