Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 37 lines (28 sloc) 0.712 kb
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
1 path File.expand_path('..', __FILE__)
2 source :gemcutter
3
79817aa @dhh Move to 3.0.0.beta
dhh authored
4 gem "rails", "3.0.0.beta"
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
5
6 gem "rake", ">= 0.8.7"
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
7 gem "mocha", ">= 0.9.8"
8
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
9 if RUBY_VERSION < '1.9'
10 gem "ruby-debug", ">= 0.10.3"
4f6d6f7 Have all the tests running off a single Gemfile
Yehuda Katz + Carl Lerche authored
11 end
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
12
13 # AR
6154278 @jeremy Fix broken autorequires
jeremy authored
14 gem "sqlite3-ruby", ">= 1.2.5", :require => 'sqlite3'
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only de...
Yehuda Katz authored
15
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
16 group :test do
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only de...
Yehuda Katz authored
17 gem "pg", ">= 0.8.0"
18 gem "mysql", ">= 2.8.1"
19 end
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
20
21 # AP
6154278 @jeremy Fix broken autorequires
jeremy authored
22 gem "rack-test", "0.5.3", :require => 'rack/test'
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
23 gem "RedCloth", ">= 4.2.2"
24
aef7e21 @jeremy Use an env var to expand the CI bundle. Using bundler's 'only' includes ...
jeremy authored
25 if ENV['CI']
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
26 gem "nokogiri", ">= 1.4.0"
6154278 @jeremy Fix broken autorequires
jeremy authored
27 gem "memcache-client", ">= 1.7.6", :require => 'memcache'
f14eb68 @jeremy CI: bundle test-unit on 1.9
jeremy authored
28
29 # fcgi gem doesn't compile on 1.9
30 # avoid minitest strangeness on 1.9
31 if RUBY_VERSION < '1.9.0'
32 gem "fcgi", ">= 0.8.7"
33 else
6154278 @jeremy Fix broken autorequires
jeremy authored
34 gem "test-unit", ">= 2.0.5", :require => 'test/unit'
f14eb68 @jeremy CI: bundle test-unit on 1.9
jeremy authored
35 end
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
36 end
Something went wrong with that request. Please try again.