Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 98 lines (78 sloc) 2.113 kB
ef8c2a8 @dasch Also use double quotes for #source
dasch authored
1 source "http://rubygems.org"
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
2
4eb0d58 @drogus Use gemspec instead of gem rails in Gemfile
drogus authored
3 gemspec
4
13df581 @tenderlove using AREL from the environment if it exists
tenderlove authored
5 if ENV['AREL']
6 gem "arel", :path => ENV['AREL']
562583c @jonleighton Add ActiveRecord::Relation#uniq for toggling DISTINCT in the SQL query
jonleighton authored
7 else
8 gem "arel", :git => "git://github.com/rails/arel"
13df581 @tenderlove using AREL from the environment if it exists
tenderlove authored
9 end
10
6779064 @guilleiguaran Remove hard dependency on bcrypt.
guilleiguaran authored
11 gem "bcrypt-ruby", "~> 3.0.0"
fe37b48 @mitijain123 Bringing back the jquery-rails. One test is dependent.
mitijain123 authored
12 gem "jquery-rails"
5f0b37c @tenderlove Switching rack-mount to journey.
tenderlove authored
13
14 if ENV['JOURNEY']
15 gem "journey", :path => ENV['JOURNEY']
16 else
17 gem "journey", :git => "git://github.com/rails/journey"
18 end
19
2f6e389 @josevalim Make compressors lazily load.
josevalim authored
20 # This needs to be with require false to avoid
21 # it being automatically loaded by sprockets
5e35d62 @arunagw Uglifier bump
arunagw authored
22 gem "uglifier", ">= 1.0.3", :require => false
2b47059 @josh Add sprockets to Gemfile for testing
josh authored
23
c930170 @arunagw No need to check ruby version here
arunagw authored
24 gem "rake", ">= 0.8.7"
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
25 gem "mocha", ">= 0.9.8"
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of …
fxn authored
26
27 group :doc do
28 gem "rdoc", "~> 3.4"
827a0fe @fxn use sdoc to generate the API
fxn authored
29 gem "sdoc", "~> 0.3"
b45a90f @tenderlove redcloth does not install on 1.9.3
tenderlove authored
30 gem "RedCloth", "~> 4.2" if RUBY_VERSION < "1.9.3"
8b25b55 @vijaydev add w3c_validators gem to the doc group to fix failing validation of …
vijaydev authored
31 gem "w3c_validators"
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of …
fxn authored
32 end
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
33
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
34 # AS
35 gem "memcache-client", ">= 1.8.5"
36
37 platforms :mri_18 do
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored
38 gem "system_timer"
2fe70c1 @josevalim Booya, sprockets now works from Engines.
josevalim authored
39 gem "json"
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored
40 end
41
a437986 @tenderlove allow people to set a local .Gemfile so that things like ruby-debug a…
tenderlove authored
42 # Add your own local bundler stuff
43 instance_eval File.read ".Gemfile" if File.exists? ".Gemfile"
29b54a4 @spastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored
44
74eb848 @zhengjia remove ruby-prof for rubinius in Gemfile
zhengjia authored
45 platforms :mri do
46 group :test do
47 gem "ruby-prof" if RUBY_VERSION < "1.9.3"
48 end
49 end
50
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
51 platforms :ruby do
e06c448 @drogus Install rb-fsevent gem if ENV[RB_FSEVENT] is set
drogus authored
52 if ENV["RB_FSEVENT"]
962936c @dasch Use quotes consistently in Gemfile
dasch authored
53 gem "rb-fsevent"
e06c448 @drogus Install rb-fsevent gem if ENV[RB_FSEVENT] is set
drogus authored
54 end
962936c @dasch Use quotes consistently in Gemfile
dasch authored
55 gem "json"
56 gem "yajl-ruby"
171491b @gazay Change version of nokogiri gem
gazay authored
57 gem "nokogiri", ">= 1.4.5"
976a9d9 @arunagw Grouped the ruby-prof into test.
arunagw authored
58
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
59 # AR
ac4763f @arunagw SQlite3 Bump
arunagw authored
60 gem "sqlite3", "~> 1.3.5"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
61
62 group :db do
3f23c04 @jonleighton Enable postgres on the CI :heart: :beer: :sparkles:
jonleighton authored
63 gem "pg", ">= 0.11.0"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
64 gem "mysql", ">= 2.8.1"
13847cc @arunagw Bump Mysql2!
arunagw authored
65 gem "mysql2", ">= 0.3.10"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
66 end
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
67 end
68
69 platforms :jruby do
d1f10e7 @arunagw Test failing with Jruby "uninitialized constant TestJSONEncoding::JSON"
arunagw authored
70 gem "json"
b2bf725 @arunagw Bump AR-JDBC version.
arunagw authored
71 gem "activerecord-jdbcsqlite3-adapter", ">= 1.2.0"
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only…
Yehuda Katz authored
72
ad13eb7 @spastorino Add a TODO to remove gem "jruby-openssl" when jruby-openssl is merge …
spastorino authored
73 # This is needed by now to let tests work on JRuby
74 # TODO: When the JRuby guys merge jruby-openssl in
75 # jruby this will be removed
ea30da3 @anildigital Add jruby-openssl gem in Gemfile necessary for JRuby
anildigital authored
76 gem "jruby-openssl"
77
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
78 group :db do
b2bf725 @arunagw Bump AR-JDBC version.
arunagw authored
79 gem "activerecord-jdbcmysql-adapter", ">= 1.2.0"
80 gem "activerecord-jdbcpostgresql-adapter", ">= 1.2.0"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
81 end
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only…
Yehuda Katz authored
82 end
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
83
84 # gems that are necessary for ActiveRecord tests with Oracle database
85 if ENV['ORACLE_ENHANCED_PATH'] || ENV['ORACLE_ENHANCED']
86 platforms :ruby do
962936c @dasch Use quotes consistently in Gemfile
dasch authored
87 gem "ruby-oci8", ">= 2.0.4"
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
88 end
89 if ENV['ORACLE_ENHANCED_PATH']
962936c @dasch Use quotes consistently in Gemfile
dasch authored
90 gem "activerecord-oracle_enhanced-adapter", :path => ENV['ORACLE_ENHANCED_PATH']
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
91 else
92 gem "activerecord-oracle_enhanced-adapter", :git => "git://github.com/rsim/oracle-enhanced.git"
93 end
94 end
b564ffc @yahonda To support ActiveRecord unit tests for IBM DB2
yahonda authored
95
8cc70cf @yahonda Fix typo in Rakefile
yahonda authored
96 # A gem necessary for ActiveRecord tests with IBM DB
b564ffc @yahonda To support ActiveRecord unit tests for IBM DB2
yahonda authored
97 gem "ibm_db" if ENV['IBM_DB']
Something went wrong with that request. Please try again.