Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 91 lines (74 sloc) 2.054 kB
ef8c2a8 @dasch Also use double quotes for #source
dasch authored
1 source "http://rubygems.org"
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
2
4eb0d58 @drogus Use gemspec instead of gem rails in Gemfile
drogus authored
3 gemspec
4
13df581 @tenderlove using AREL from the environment if it exists
tenderlove authored
5 if ENV['AREL']
6 gem "arel", :path => ENV['AREL']
7 else
1c23887 @guilleiguaran Bump ARel to 2.1.3
guilleiguaran authored
8 gem "arel", '~> 2.1.3'
13df581 @tenderlove using AREL from the environment if it exists
tenderlove authored
9 end
10
fe37b48 @mitijain123 Bringing back the jquery-rails. One test is dependent.
mitijain123 authored
11 gem "jquery-rails"
2f6e389 @josevalim Make compressors lazily load.
josevalim authored
12 # This needs to be with require false to avoid
13 # it being automatically loaded by sprockets
14 gem "uglifier", ">= 1.0.0", :require => false
2b47059 @josh Add sprockets to Gemfile for testing
josh authored
15
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
16 gem "rake", ">= 0.8.7"
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
17 gem "mocha", ">= 0.9.8"
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of …
fxn authored
18
19 group :doc do
20 gem "rdoc", "~> 3.4"
21 gem "horo", "= 1.0.3"
b45a90f @tenderlove redcloth does not install on 1.9.3
tenderlove authored
22 gem "RedCloth", "~> 4.2" if RUBY_VERSION < "1.9.3"
8b25b55 @vijaydev add w3c_validators gem to the doc group to fix failing validation of …
vijaydev authored
23 gem "w3c_validators"
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of …
fxn authored
24 end
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
25
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
26 # AS
27 gem "memcache-client", ">= 1.8.5"
28
29 platforms :mri_18 do
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored
30 gem "system_timer"
d664eba @joshk Added a .travis.yml config and travis specific ci script.
joshk authored
31 gem "ruby-debug", ">= 0.10.3" unless ENV['TRAVIS']
2fe70c1 @josevalim Booya, sprockets now works from Engines.
josevalim authored
32 gem "json"
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored
33 end
34
29b54a4 @spastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored
35 platforms :mri_19 do
36 # TODO: Remove the conditional when ruby-debug19 supports Ruby >= 1.9.3
d664eba @joshk Added a .travis.yml config and travis specific ci script.
joshk authored
37 gem "ruby-debug19", :require => "ruby-debug" unless RUBY_VERSION > "1.9.2" || ENV['TRAVIS']
29b54a4 @spastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored
38 end
39
74eb848 @zhengjia remove ruby-prof for rubinius in Gemfile
zhengjia authored
40 platforms :mri do
41 group :test do
42 gem "ruby-prof" if RUBY_VERSION < "1.9.3"
43 end
44 end
45
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
46 platforms :ruby do
e06c448 @drogus Install rb-fsevent gem if ENV[RB_FSEVENT] is set
drogus authored
47 if ENV["RB_FSEVENT"]
962936c @dasch Use quotes consistently in Gemfile
dasch authored
48 gem "rb-fsevent"
e06c448 @drogus Install rb-fsevent gem if ENV[RB_FSEVENT] is set
drogus authored
49 end
962936c @dasch Use quotes consistently in Gemfile
dasch authored
50 gem "json"
51 gem "yajl-ruby"
171491b @gazay Change version of nokogiri gem
gazay authored
52 gem "nokogiri", ">= 1.4.5"
976a9d9 @arunagw Grouped the ruby-prof into test.
arunagw authored
53
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
54 # AR
421e06f @tenderlove updating gem dependency for sqlite3
tenderlove authored
55 gem "sqlite3", "~> 1.3.3"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
56
57 group :db do
d664eba @joshk Added a .travis.yml config and travis specific ci script.
joshk authored
58 gem "pg", ">= 0.11.0" unless ENV['TRAVIS'] # once pg is on travis this can be removed
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
59 gem "mysql", ">= 2.8.1"
301cad4 @guilleiguaran Bump to mysql2 0.3.6
guilleiguaran authored
60 gem "mysql2", ">= 0.3.6"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
61 end
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
62 end
63
64 platforms :jruby do
65 gem "ruby-debug", ">= 0.10.3"
d1f10e7 @arunagw Test failing with Jruby "uninitialized constant TestJSONEncoding::JSON"
arunagw authored
66 gem "json"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
67 gem "activerecord-jdbcsqlite3-adapter"
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only…
Yehuda Katz authored
68
ad13eb7 @spastorino Add a TODO to remove gem "jruby-openssl" when jruby-openssl is merge …
spastorino authored
69 # This is needed by now to let tests work on JRuby
70 # TODO: When the JRuby guys merge jruby-openssl in
71 # jruby this will be removed
ea30da3 @anildigital Add jruby-openssl gem in Gemfile necessary for JRuby
anildigital authored
72 gem "jruby-openssl"
73
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
74 group :db do
75 gem "activerecord-jdbcmysql-adapter"
76 gem "activerecord-jdbcpostgresql-adapter"
77 end
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only…
Yehuda Katz authored
78 end
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
79
80 # gems that are necessary for ActiveRecord tests with Oracle database
81 if ENV['ORACLE_ENHANCED_PATH'] || ENV['ORACLE_ENHANCED']
82 platforms :ruby do
962936c @dasch Use quotes consistently in Gemfile
dasch authored
83 gem "ruby-oci8", ">= 2.0.4"
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
84 end
85 if ENV['ORACLE_ENHANCED_PATH']
962936c @dasch Use quotes consistently in Gemfile
dasch authored
86 gem "activerecord-oracle_enhanced-adapter", :path => ENV['ORACLE_ENHANCED_PATH']
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
87 else
88 gem "activerecord-oracle_enhanced-adapter", :git => "git://github.com/rsim/oracle-enhanced.git"
89 end
90 end
Something went wrong with that request. Please try again.