Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 30 lines (25 sloc) 1.248 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
version = File.read(File.expand_path("../../RAILS_VERSION", __FILE__)).strip

Gem::Specification.new do |s|
  s.platform = Gem::Platform::RUBY
  s.name = 'actionpack'
  s.version = version
  s.summary = 'Web-flow and rendering framework putting the VC in MVC (part of Rails).'
  s.description = 'Web apps on Rails. Simple, battle-tested conventions for building and testing MVC web applications. Works with any Rack-compatible server.'
  s.required_ruby_version = '>= 1.8.7'

  s.author = 'David Heinemeier Hansson'
  s.email = 'david@loudthinking.com'
  s.homepage = 'http://www.rubyonrails.org'
  s.rubyforge_project = 'actionpack'

  s.files = Dir['CHANGELOG', 'README.rdoc', 'MIT-LICENSE', 'lib/**/*']
  s.require_path = 'lib'
  s.requirements << 'none'

  s.add_dependency('activesupport', version)
  s.add_dependency('activemodel', version)
  s.add_dependency('builder', '~> 2.1.2')
  s.add_dependency('i18n', '~> 0.5.0')
  s.add_dependency('rack', '~> 1.2.1')
  s.add_dependency('rack-test', '~> 0.5.7')
  s.add_dependency('rack-mount', '~> 0.6.14')
  s.add_dependency('tzinfo', '~> 0.3.23')
  s.add_dependency('erubis', '~> 2.6.6')
end
Something went wrong with that request. Please try again.