Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Load RAILS_VERSION relative to the gemspec file.

  • Loading branch information...
commit 4bc2cbc3cfa231b3dea0dce38a6fa2723c7ed94d 1 parent 3789539
@stefanpenner stefanpenner authored wycats committed
View
2  actionmailer/actionmailer.gemspec
@@ -1,4 +1,4 @@
-version = File.read("../RAILS_VERSION").strip
+version = File.read(File.expand_path("../../RAILS_VERSION", __FILE__)).strip
Gem::Specification.new do |s|
s.platform = Gem::Platform::RUBY
View
2  actionpack/actionpack.gemspec
@@ -1,4 +1,4 @@
-version = File.read("../RAILS_VERSION").strip
+version = File.read(File.expand_path("../../RAILS_VERSION", __FILE__)).strip
Gem::Specification.new do |s|
s.platform = Gem::Platform::RUBY
View
2  activemodel/activemodel.gemspec
@@ -1,4 +1,4 @@
-version = File.read("../RAILS_VERSION").strip
+version = File.read(File.expand_path("../../RAILS_VERSION", __FILE__)).strip
Gem::Specification.new do |s|
s.platform = Gem::Platform::RUBY
View
2  activerecord/activerecord.gemspec
@@ -1,4 +1,4 @@
-version = File.read("../RAILS_VERSION").strip
+version = File.read(File.expand_path("../../RAILS_VERSION", __FILE__)).strip
Gem::Specification.new do |s|
s.platform = Gem::Platform::RUBY
View
2  activeresource/activeresource.gemspec
@@ -1,4 +1,4 @@
-version = File.read("../RAILS_VERSION").strip
+version = File.read(File.expand_path("../../RAILS_VERSION", __FILE__)).strip
Gem::Specification.new do |s|
s.platform = Gem::Platform::RUBY
View
2  activesupport/activesupport.gemspec
@@ -1,4 +1,4 @@
-version = File.read("../RAILS_VERSION").strip
+version = File.read(File.expand_path("../../RAILS_VERSION", __FILE__)).strip
Gem::Specification.new do |s|
s.platform = Gem::Platform::RUBY
View
2  rails.gemspec
@@ -1,4 +1,4 @@
-version = File.read("RAILS_VERSION").strip
+version = File.read(File.expand_path("../RAILS_VERSION",__FILE__)).strip
Gem::Specification.new do |s|
s.platform = Gem::Platform::RUBY
View
2  railties/railties.gemspec
@@ -1,4 +1,4 @@
-version = File.read("../RAILS_VERSION").strip
+version = File.read(File.expand_path("../../RAILS_VERSION", __FILE__)).strip
Gem::Specification.new do |s|
s.platform = Gem::Platform::RUBY
Please sign in to comment.
Something went wrong with that request. Please try again.